Help with Revise

Revise is not working for me. I have a package in development called CaRs here:

The source code is the usual “Hello World” test:

Which works fine, before making changes:

And yet the output of greet() is the same when I change “Hello GB World” to “Hello World” in …/src/CaRs.jl and save the file. Similarly, if I comment out the export greet line I’m still able to execute greet() as well as CaRs.greet().

Any ideas as to what I might be doing wrong? This is my first attempt to use Revise and I was looking forward to the labor-saving aspect…

Do import Pkg; Pkg.activate(".") before using Revise and see if it works.

No, that doesn’t change anything.

Ah wait, add in cd(path_to_CaRs_directory) at the start as well.

If you mean go to …/dev/CaRs before starting Julia then I already tried it, with no success

Can you check with pwd() inside the session? Just to be certain?

This is what I think you were suggesting I try. No joy…

1 Like

See Revise v3.3.0 seems broken · Issue #664 · timholy/Revise.jl · GitHub

Try downgrading Revise to 3.2.1.
] add Revise@3.2.1 or add using Revise to your startup.jl

Thank you @mkitti. That worked :smiley:

Obviously, I should have looked at Issues · timholy/Revise.jl · GitHub Next time I have an issue with a package I’ll look at package issues first!

Yes, that is usually a good place to start. It is also a good place to report issues.