I just wrote a function called the to extract properties from an object. So you can do object.property or the(property, object) in a partially-applied way: the(property)(object). Bad idea?
Edit: It works fine, but I’m wondering if a name like “the” should be saved for better purposes.
Yes. It works fine, but I’m wondering if a name like “the” should be saved for better purposes. I’ll add this explanation to my original post actually.
I hadn’t looked into it much. I might not use it for now because I don’t really need to “mutate” immutable structs for what I’m working on. But thanks for the pointer.