GMT.jl Installation on Windows 10

Hello,

Is there anyone who was able to successfully install GMT.jl? I am trying to run following:

However, getting following error:

error compiling common_plot_xyz: error compiling gmt: could not load library “gmt_w64”
The specified module could not be found.

Is there anyone knowing the solution?
Thank you,

I hate when I see that The specified module could not be found error because it means stupid Windows is not able to tell the name of the module that could not be found. Normally it’s a dependency problem, and from GMT in this case. I’m assuming you installed GMT6 from its Windows installer, right? What does this print?

run(`gmt --version`)

also, does this command run from Win cmd (NOT the Julia REPL) show a red circle, or complains with same gmt_w64 error?

echo 1 1 | gmt plot -Ba -Sc0.5 -Gred -png map

But better that you open an issue in GMT.jl where we can continue this talk.

Hello,

Yes, I installed GMT6 (gmt-6.0.0-win64). I would like to be sure that I understand the ways you mentioned correctly:

  1. Where do I do “run(‘gmt --version’)” ?
    I run it at julia REPL, it gave me this:
    image

  2. The second command showed me a red circle like this:

  3. What do you mean by GMT.jl? I couldn’t find any package category post regarding to GMT.jl, do you mean Github?

Thank you very much

Yes GMT.jl is the github site (but GMT is also in github).

The fact that it worked on the cmd is even more confusing because it uses exactly the same binaries. The Julia REPL error is for sure due to a copy paste change of characters. It needs to be back-ticks. This is what I get (but note that I’m using GMT master version)

julia> run(`gmt --version`)
6.1.0_3f96917-dirty_2020.01.02

Dear all,

The problem was solved, it is all about version issue.

I deleted the GMT.jl at …julia\compiled\v1.3\GMT, and it worked.

Check https://github.com/GenericMappingTools/GMT.jl/issues/328 for more details.

1 Like