GitError when starting the REPL view in Juno

juno

#1

After some problems with Juno, I tried uninstalling Julia and Juno (including deleting related folders under Users: “.atom” and “AppData/Local/Julia”) and installing from scratch.

The first difficulty was that Pkg.update() asked to run Pkg.init() first, but this fails with

ERROR: GitError(Code:ERROR, Class:OS, Failed to mark Git repository folder as hidden: )

This was fixed by rebooting and running Pkg.init() again (I also tried manually marking the folder as hidden, but that did not help before rebooting, so I don’t know if it mattered).

After installing the uber-juno package and restarting Atom, the new REPL view says “Press Enter to start Julia”. When pressing Enter I got Starting Julia..., but no further output. Pressing Enter again yields more copies of the Starting Julia... message.
After restarting Atom and trying again, I get the following:

Press Enter to start Julia. Starting Julia...
juno-msg-installingjuno-msg-installERROR: LoadError: GitError(Code:ENOTFOUND, Class:Repository, Could not find repository from 'C:\Users\yharel\AppData\Local\Julia\v0.6\.cache\ASTInterpreter2')
macro expansion at .\libgit2\error.jl:99 [inlined]
Base.LibGit2.GitRepo(::String) at .\libgit2\repository.jl:10
prefetch(::String, ::String, ::Array{String,1}) at .\pkg\cache.jl:41
resolve(::Dict{String,Base.Pkg.Types.VersionSet}, ::Dict{String,Dict{VersionNumber,Base.Pkg.Types.Av
ailable}}, ::Dict{String,Tuple{VersionNumber,Bool}}, ::Dict{String,Base.Pkg.Types.Fixed}, ::Dict{Str
ing,VersionNumber}, ::Set{String}) at .\pkg\entry.jl:516
resolve(::Dict{String,Base.Pkg.Types.VersionSet}, ::Dict{String,Dict{VersionNumber,Base.Pkg.Types.Av
ailable}}, ::Dict{String,Tuple{VersionNumber,Bool}}, ::Dict{String,Base.Pkg.Types.Fixed}) at .\pkg\e
ntry.jl:479
edit(::Function, ::String, ::Base.Pkg.Types.VersionSet, ::Vararg{Base.Pkg.Types.VersionSet,N} where
N) at .\pkg\entry.jl:30
(::Base.Pkg.Entry.##1#3{String,Base.Pkg.Types.VersionSet})() at .\task.jl:335
Stacktrace:
 [1] sync_end() at .\task.jl:287
 [2] macro expansion at .\task.jl:303 [inlined]
 [3] add(::String, ::Base.Pkg.Types.VersionSet) at .\pkg\entry.jl:51
 [4] (::Base.Pkg.Dir.##3#6{Array{Any,1},Base.Pkg.Entry.#add,Tuple{String}})() at .\pkg\dir.jl:33
 [5] cd(::Base.Pkg.Dir.##3#6{Array{Any,1},Base.Pkg.Entry.#add,Tuple{String}}, ::String) at .\file.jl
:59
 [6] withenv(::Base.Pkg.Dir.##2#5{Array{Any,1},Base.Pkg.Entry.#add,Tuple{String},String}, ::Pair{Str
ing,String}, ::Vararg{Pair{String,String},N} where N) at .\env.jl:157
 [7] #cd#1(::Array{Any,1}, ::Function, ::Function, ::String, ::Vararg{String,N} where N) at .\pkg\di
r.jl:32
 [8] add(::String) at .\pkg\pkg.jl:117
 [9] include_from_node1(::String) at .\loading.jl:576
 [10] include(::String) at .\sysimg.jl:14
 [11] process_options(::Base.JLOptions) at .\client.jl:305
 [12] _start() at .\client.jl:371
while loading C:\Users\yharel\.atom\packages\julia-client\script\boot_repl.jl, in expression startin
g on line 11

Running Pkg.add("Atom") in Julia yields the same error.

Any ideas how to proceed would be appreciated.


#2

In case anybody else encounters these problems: I found both of the issues in my first post were caused by McAffee Endpoint Security finding julia.exe “suspicious”. Reinstalling McAffee fixed it for now.