GenieBuilder unable to install package

I get the following error:

Pkg.add(url = “GitHub - GenieFramework/GenieBuilder.jl”)
Cloning git-repo
Updating git-repo
Resolving package versions…
ERROR: Unsatisfiable requirements detected for package Temporal [a110ec8f]:
Temporal [a110ec8f] log:
├─possible versions are: 0.5.0-0.8.1 or uninstalled
├─restricted by compatibility requirements with HTTP [cd3eb016] to versions: uninstalled
│ └─HTTP [cd3eb016] log:
│ ├─possible versions are: 0.6.10-1.10.0 or uninstalled
│ └─restricted to versions 1 by GenieBuilder [c9453c14], leaving only versions: 1.0.0-1.10.0
│ └─GenieBuilder [c9453c14] log:
│ ├─possible versions are: 0.15.12 or uninstalled
│ └─GenieBuilder [c9453c14] is fixed to version 0.15.12

I have uninstalled Temporal but I still get the same error. What is going on?

uninstalled all packages. Uninstalling Temporal did not work. Deleted all julia related folders manually. Uninstalling julia by going to windows Add or remove programs did not work either so had to do everything manually to get GenieBuilder to work

1 Like

The first words in the readme:

This is the backend (web service) powering the GenieBuilder VSCode plugin. Unless you want to contribute to the backend, this repo is not what you want.

If you want to install the GenieBuilder VSCode plugin, please visit the VSCode marketplace or use this link to install it: Genie Builder - Visual Studio Marketplace

Are you looking to develop the backend, or use it? If you want to use it, do so via VSCode.

1 Like

I am not sure what you mean because when trying to start the server in vscode is when i got that error. Yes, i was looking for nocode ui builder but that wouldn’t work until I successfully installed this. And the webpage u mentioned is where I went to install and get started and got stuck when starting the server

1 Like

You accidentally marked one of the comments of yourself as the solution to this problem.

And you seem to add the GenieBuilder plugin via the REPL. This is not how you do it.
Install it as a normal VSCode extension, as shown in the repo and the answer by @TheLateKronos