Flux & Julia v. 1.1.1

I just upgraded Julia to v. 1.1.1, and have updated packages.

When I run using Flux, I get error messages. The status of Flux is:

(v1.1) pkg> status Flux
    Status `C:\Users\my_username\.julia\environments\v1.1\Project.toml`
  [587475ba] Flux v0.8.3
  [e5e0dc1b] Juno v0.7.0
  [2913bbd2] StatsBase v0.30.0
  [9a3f8284] Random

The error message from using Flux is:

julia> using Flux
[ Info: Precompiling Flux [587475ba-b771-5e3f-ad9e-33799f191a9c]
ERROR: LoadError: LoadError: InitError: C:\Users\my_username\.julia\packages\SpecialFunctions\fvheQ\deps\usr\bin\libopenspecfun.dll cannot be opened, Please re-run Pkg.build("fvheQ"), and restart Julia.

If I try to build the fvheQ, I get the following error message:

ERROR: The following package names could not be resolved:
 * fvheQ (not found in project or manifest)
Please specify by known `name=uuid`.

Anyone has an idea of the cause of the problem?

Looks like there’s a bug in the error message formatter; I would try

julia> Pkg.build("SpecialFunctions")

as my next step.



julia> Pkg.build("SpecialFunctions")

solved the problem – so a bug in the error message.
Now, my test notebook with Flux works. The only thing that didn’t work now, was a command I seem to recall I took from the Flux documentation:

julia> Trainer.back!(cost)

which I believe was a manual issuing of doing back propagation. Perhaps this function (Trainer.back!()) has changed name?

1 Like