FFTW fails to build

I did an

] update

and FFTW failed with this message

(@v1.4) pkg> build FFTW

Building FFTW → ~/.julia/packages/FFTW/kcXL6/deps/build.log
┌ Error: Error building FFTW:
│ ERROR: LoadError: ArgumentError: Package LinearAlgebra not found in current path:
│ - Run import Pkg; Pkg.add("LinearAlgebra") to install the LinearAlgebra package.

│ Stacktrace:
│ [1] require(::Module, ::Symbol) at ./loading.jl:892
│ [2] include(::String) at ./client.jl:439
│ [3] top-level scope at none:5
│ in expression starting at /Users/ctk/.julia/packages/FFTW/kcXL6/deps/build.jl:1

so I did (LinearAlgebra was already installed, but I tried again anyhow)

] add LinearAlgebra
] build LinearAlgebra
] build FFTW

and got the same error message. Any ideas?

1 Like

Never mind. I did

] rm FFTW
] add FFTW

restarted Julia and typed this in the REPL

> using FFTW

got (no mention of LinearAlgebra)

ERROR: LoadError: FFTW is not properly installed. Please run Pkg.build(“FFTW”) and restart Julia.

Did as advised and all seems to be well. Is there a reason my first attempt failed?

1 Like