Failed to precompile Pkg because Quat not defined


I try to use the branch of Pkg,but actually stuck in this trouble. It is a problem of the Pkg itself?
I definitely guess that global variable causes the mistake .
Any tips? Thank u :heart:

I saw that you already reported an issue at TrajectoryOptimisation, that’s good.

A few things you could do:

  1. What is the output of import Pkg; Pkg.status(). It seems like your TrajectoryOptimisation package is not up-to-date. At least <= v0.2. Can you install a newer version?
  2. JuliaPro has sometimes a bit outdated packages. You could try a normal Julia installation. (For getting a JuliaPro like enviroment you can follow these instructions: http://docs.junolab.org/latest/man/installation/ )
  3. If you cannot install a newer version, maybe you can install an older version of the package and hope that the bug was not present then.

I tried v0.3 of the package and it worked on my machine. I think the bug is already fixed in the new versions.

1 Like

yeap! I found that the version of Rotations causes the bug.An older version can avoid this issue with “Quats”.
Thank u for reply!