Fail to set Gallium breakpoint at a specified line in a file

gallium
debug

#1

I tried to set a breakpoint at a line in a file by first changing pwd to the folder where the file is and then call breakpoint as follows:

julia> breakpoint("my_file.jl", 183)
Locations (+: active, -: inactive, *: source):
 * Any method reaching my_file.jl:183

But it seemed no breakpoint was set as nothing was returned when I typed in Gallium.list_breakpoints(). :confused:

Any hint? Thanks!


#2

Setting the breakpoints actually works, but they aren’t properly registering internally (which also means you can’t remove them), This was fixed in #168, but there hasn’t been a new release since then. If you need this functionality right now, try checking out Gallium (and proably some of it’s dependencies).


#3

Thanks for pointing that out. But it seems that my problem is more than just “improper registration of breakpoints”. Because the debugger never stops there, implying no breakpoints at all. I suspect that there are something that I missed when using Gallium, e.g. missing quotes etc. Am I using the command correctly?


#4

Maybe try using the whole file path, that might work more reliably.


#5

Thanks. Tried the full path, no change :frowning: .