Error while installing Packages

Hi I am new to Julia.

When I try to install several packages (JuMP, CSV, …) with

import Pkg

I get

Resolving package versions…
ERROR: cannot find name corresponding to UUID 8bb1440f-4735-579b-a4ab-409b98df4dab in a registry

Can you help me fix it?

Many thank sin advance.

Version info:

Default Channel Version Update

   *  release  1.10.3+0.x64.w64.mingw32

Status C:\Users\xxx\AppData\Local\NEMO\depot\environments\v1.10\Project.toml
[682c06a0] JSON v0.21.0


] registry up
1 Like

I agree with Mark’s recommendation to try ] registry up.

I would also be curious to see the output of running ] registry status.

Thank you for replying.

I tried as indicated but I still get the same error when trying to add the package.

Thank you for replying.
I get still the same error after trying: ] registry up.

I send the registry status below:
Registry Status
[23338594] General (GitHub - JuliaRegistries/General: The official registry of general Julia packages)
[ef78e00e] NEMORegistry (C:/Users/Jason/Dropbox/Research/Next Gen Modeling/Julia/Nemo Installer/NEMO_registry)

How did you install Julia?

What is the output of:


And do you need the NEMORegistry? What do you need it for? If you do not need it, can you try to remove it?

Something is very wrong. That UUID belongs to DelimitedFiles.jl, a standard library package.

Could you provide the output of the following?


julia> LOAD_PATH

julia> Base.load_path()

julia> using DelimitedFiles

julia> pathof(DelimitedFiles)

4-element Vector{String}:

julia> LOAD_PATH
3-element Vector{String}:

julia> Base.load_path()
2-element Vector{String}:
“C:\Users\xxx.julia\juliaup\j” ⋯ 23 bytes ⋯ “ingw32\share\julia\stdlib\v1.10”

julia> using DelimitedFiles
*no output

julia> pathof(DelimitedFiles)

Is there really a \ missing after your username? It should be “C:\Users\xxx\.julia”.

I installed Julia via Microsoft Store with

winget install julia -s msstore

I should not need NEMORegistry, I am removing it.
I send the versioninfo() below:

julia> versioninfo()
Julia Version 1.10.3
Commit 0b4590a550 (2024-04-30 10:59 UTC)
Build Info:
Official release
Platform Info:
OS: Windows (x86_64-w64-mingw32)
CPU: 8 × Intel(R) Core™ i7-8550U CPU @ 1.80GHz
LIBM: libopenlibm
LLVM: libLLVM-15.0.7 (ORCJIT, skylake)
Threads: 4 default, 0 interactive, 2 GC (on 8 virtual cores)
JULIA_DEPOT_PATH = C:\Users\xxx\AppData\Local\NEMO\depot;

This is unusual and potentially problematic. What instructions did you follow to install the NEMO things?

Edit: This thread looks similar: Julia adding an older version of my updated Gurobi Solber - #17 by odow

No, sorry. The character \ is not missing.


Thank you very much for following up. I will try to find another way to install Julia.

I tried to install Julia again through an installer from the official website instead from MS store, but got the same result. I gave up and switch to an Ubuntu virtual machine. Now it is working perfectly.