Error using Agents.jl

I am trying to simulate the example that is published in the documentation of Agents.jl - Continuous Space Social Distancing for COVID 19. Despite installing the required packages, I still get the following error,

ERROR: LoadError: UndefVarError: ContinuousSpace not defined
Stacktrace:
 [1] motion(; speed::Float64) at /Users/narayanivedam/Dropbox/Research/Simulations/Julia/2020_Final/COVID_TRIAL.jl:11
 [2] motion() at /Users/narayanivedam/Dropbox/Research/Simulations/Julia/2020_Final/COVID_TRIAL.jl:11
 [3] top-level scope at /Users/narayanivedam/Dropbox/Research/Simulations/Julia/2020_Final/COVID_TRIAL.jl:25
 [4] include(::String) at ./client.jl:439
 [5] top-level scope at none:0
in expression starting at /Users/narayanivedam/Dropbox/Research/Simulations/Julia/2020_Final/COVID_TRIAL.jl:25

How do I fix this ?

Have you tried using the master branch of the package?

I use Julia version 1.4. How do I ensure that the package I use is the one in the master branch?

] add Agents#master

1 Like

I get the following error

    Cloning git-repo `https://github.com/JuliaDynamics/Agents.jl.git`
   Updating git-repo `https://github.com/JuliaDynamics/Agents.jl.git`
   Updating registry at `~/.julia/registries/General`
   Updating git-repo `https://github.com/JuliaRegistries/General.git`
  Resolving package versions...
ERROR: Unsatisfiable requirements detected for package AgentsPlots [7820620d]:
 AgentsPlots [7820620d] log:
 ├─possible versions are: [0.1.0-0.1.2, 0.2.0-0.2.1] or uninstalled
 ├─restricted to versions * by an explicit requirement, leaving only versions [0.1.0-0.1.2, 0.2.0-0.2.1]
 └─restricted by compatibility requirements with Agents [46ada45e] to versions: uninstalled — no versions left
   └─Agents [46ada45e] log:
     ├─possible versions are: 3.0.0 or uninstalled
     └─Agents [46ada45e] is fixed to version 3.0.0

Maybe you should raise an issue on the repo. I believe they are working on a new version and it looks like maybe things got a bit out of sync?

Yes, this is the problem. We are nearly done with a big v3 upgrade - this is introducing breaking changes in both Agents and AgentsPlots. To run the latest examples you’ll need to use the master version of both packages.

]add Agents#master
]add AgentsPlots#master
1 Like

@ennvvy I can not find ContinuousSpace anywhere in the stable documentation: https://juliadynamics.github.io/Agents.jl/stable/

You are probably reading the master documentation. In this scenario, the fact that we are in a transition period to version 3.0 is irrelevant. The master version of the docs always corresponds to the master version of the packages. This is not an issue in my eyes, but a fact, and it holds for other repositories as well. (Notice also that the very first message in the documentation “Latest news” tells you to do that as well)

So, for the future, if you are reading the master version of the docs of a package, be sure to also have the master version installed; it will save you confusion! :slight_smile:

2 Likes

Thanks, That fixed it.