ERROR: Unsatisfiable requirements detected for package FactCheck [01605889]

I’m trying to install the package DeterminantalPointProcesses.jl of alshedivat from Github, but I get the following error message:

ERROR: Unsatisfiable requirements detected for package FactCheck [01605889]:
FactCheck [01605889] log:
├─possible versions are: [0.0.1-0.0.2, 0.1.0-0.1.2, 0.2.0-0.2.9, 0.3.0-0.3.1, 0.4.0-0.4.3] or uninstalled
├─restricted by compatibility requirements with DeterminantalPointProcesses [9d4a7304] to versions: 0.4.3
│ └─DeterminantalPointProcesses [9d4a7304] log:
│ ├─possible versions are: 0.0.1 or uninstalled
│ └─restricted to versions * by an explicit requirement, leaving only versions 0.0.1
└─restricted by julia compatibility requirements to versions: uninstalled — no versions left

Any suggestion? I’m using JuliaPro 1.2.

It seems the problem is that the package author has not registered a Julia 1.0 compatible version of this package. Perhaps you should file an issue on In the meantime, you should be able to circumvent the resolver with pkg> add DeterminantalPointProcess#master.

For reference:
FactCheck.jl is super old.
It has not ever worked on anything newer than Julia 0.4

But yes, DetermanisticPointProcesses.jl#master no-longer uses it.

Thank you to both of you! After I run pkg> add DeterminantalPointProcesses#master, the installation and compiling worked perfectly!

I was the one doing a PR to get 1.0 compatibility unfortunately the author never made a release for it.
@sergevic if you are interested in improving and maintaining the package, we could contact the author to ask for access to the repo.