ERROR: Unable to find compatible target in system image (julia 1.9.0)

Hi everyone,

With julia 1.8.5 (PackageCompiler v2.1.5) it works but when I recently upgraded to julia 1.9.0 (PackageCompiler v2.1.5) and deploy the same julia package in a container using PackageCompiler it results in the following error message: ERROR: Unable to find compatible target in system image.

When creating the sysimage I’m using the following cpu target: cpu_target = "generic;native,sandybridge,-xsaveopt,clone_all;haswell,-rdrnd,base(1)"

I’ve experimented with different arguments here but none seem to work, only to downgrade back to 1.8.5. Any suggestions would be very welcomed.

The sysimage created with julia 1.9.0 works locally on my laptop but not on the target cpu. The target lscpu gives this information:

Architecture:            x86_64
  CPU op-mode(s):        32-bit, 64-bit
  Address sizes:         46 bits physical, 48 bits virtual
  Byte Order:            Little Endian
CPU(s):                  80
  On-line CPU(s) list:   0-79
Vendor ID:               GenuineIntel
  Model name:            Intel(R) Xeon(R) Gold 5218R CPU @ 2.10GHz
    CPU family:          6
    Model:               85
    Thread(s) per core:  2
    Core(s) per socket:  20
    Socket(s):           2
    Stepping:            7
    Frequency boost:     enabled
    CPU max MHz:         2101.0000
    CPU min MHz:         800.0000
    BogoMIPS:            4200.00
    Flags:               fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx pdpe1gb rdtscp lm constant_tsc art arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc cpuid aperfmperf pni pclmulqdq dtes
                         64 monitor ds_cpl vmx smx est tm2 ssse3 sdbg fma cx16 xtpr pdcm pcid dca sse4_1 sse4_2 x2apic movbe popcnt tsc_deadline_timer aes xsave avx f16c rdrand lahf_lm abm 3dnowprefetch cpuid_fault epb cat_l3 cdp_l3 invpcid_single intel_ppin ssbd mba ibrs ibpb stibp 
                         ibrs_enhanced tpr_shadow vnmi flexpriority ept vpid fsgsbase tsc_adjust bmi1 avx2 smep bmi2 erms invpcid cqm mpx rdt_a avx512f avx512dq rdseed adx smap clflushopt clwb intel_pt avx512cd avx512bw avx512vl xsaveopt xsavec xgetbv1 xsaves cqm_llc cqm_occup_llc cq
                         m_mbm_total cqm_mbm_local dtherm ida arat pln pts pku ospke avx512_vnni md_clear flush_l1d arch_capabilities
Virtualization features: 
  Virtualization:        VT-x
Caches (sum of all):     
  L1d:                   1.3 MiB (40 instances)
  L1i:                   1.3 MiB (40 instances)
  L2:                    40 MiB (40 instances)
  L3:                    55 MiB (2 instances)
  NUMA node(s):          2
  NUMA node0 CPU(s):     0-19,40-59
  NUMA node1 CPU(s):     20-39,60-79
  Itlb multihit:         KVM: Mitigation: Split huge pages
  L1tf:                  Not affected
  Mds:                   Not affected
  Meltdown:              Not affected
  Mmio stale data:       Mitigation; Clear CPU buffers; SMT vulnerable
  Spec store bypass:     Mitigation; Speculative Store Bypass disabled via prctl and seccomp
  Spectre v1:            Mitigation; usercopy/swapgs barriers and __user pointer sanitization
  Spectre v2:            Mitigation; Enhanced IBRS, IBPB conditional, RSB filling
  Srbds:                 Not affected
  Tsx async abort:       Mitigation; TSX disabled

Not sure if it’s the same, but this error message came up on Slack recently and a fix that might address it is here:

I think this should be available on PkgCompiler master so give it a try.

1 Like

Thank you so much! It solved the issue using master:

import Pkg;
Pkg.add(name="PackageCompiler", rev="master")
1 Like

Glad it worked! I think Kristoffer is planning a patch release soon so you shouldn’t have to stay on master for too long.

1 Like