Compiling a portable shared lib with PackageCompiler

So, I’m in a situation at work where I’m trying to build a docker image to run on the “AWS Batch” service (it just runs docker containers), preferably with a compiled system image from PackageCompiler.

My docker images always work just fine locally, but when I try running on AWS I always get

ERROR: Unable to find compatible target in system image.

I’ve tried running my PackageCompiler compilation script with julia -Cgeneric compile.jl and very much to my surprise, I still get the same error with this.

Has anyone ever run into an analogous problem? Any suggestions?

What does that mean? Do you pass the cpu_target to PackageCompiler when you create the sysimage?

1 Like

Wow, I’m such an idiot.

I didn’t realize that PackageCompiler had a separate option, I thought it was inheriting it from the Julia run-time.

A couple of us got ourselves really confused about this on slack I think.

Yeah, haven’t been able to test on AWS yet, but I found a machine I couldn’t run the older binaries on, so hopefully that was it, thanks!