ERROR: stat returned zero type for a valid path

I tried to upgrade from Julia 1.2.0 to 1.3.1 on my Andoid/userLAnd/Ubuntu installation - and encountered a new error message upon launching Julia 1.3.1. It probably has to do with some missing folder or writing rights, but I cannot figure it out. Any ideas?

The error message is

ERROR: stat returned zero type for a valid path
Stacktrace:
[1] error(::String) at ./error.jl:33
[2] stat(:String) at ./stat.jl:73
[3] isfile at ./stat.jl:311 [inlined]
[4] load_julia_startup() at ./client.jl:314
[5] exec_options(::Base.JLOptions) at ./client.jl:258
[6] _start() at ./client.jl:460

(The installation follows the same installation routine as in this discourse thread.)

Usually the full error message is important, so maybe you can include:

1 Like

Check the permissions on the dir / file it is trying to look at.

tried to type it in (see edited original post)

Thanks for the hints. This has helped. In particular, this partial solution
julia --startup-file=no --history-file=no
works with Julia 1.3.1. For some reason Julia 1.2.0 works without those flags.

An uninformed guess is that 1.3.1 requires access to some folders on startup, while 1.2.0 does not.

Still, this works well enough for now.