Error precompiling DifferentialEquations: NonlinearLeastSquaresProblem not defined

I am using Julia 1.8.5 in VSCode on Windows.

I just started a new environment using

import Pkg
Pkg.activate("math", shared=true)

Then I tried to install DifferentialEquations, but got the following error:

Precompiling DifferentialEquations [0c46a032-eb83-5123-abaf-570d42b7fbaa]
ERROR: LoadError: UndefVarError: NonlinearLeastSquaresProblem not defined

The actual error happens when precompiling a dependency: Failed to precompile SimpleNonlinearSolve, and the first error message comes from .julia\packages\SimpleNonlinearSolve\nusbP\src\raphson.jl:66.

I tried to Pkg.update() (which maybe doesn’t make much sense), and also restarting the notebook, but none of this worked.

Thanks for any help!


I have the same issue in Julia 1.9.3, however someone has created an issue on SimpleNonlinearSolve.jl. If you want an immediate way to run your notebook, downgrading SimpleNonlinearSolve from v0.1.24 to v0.1.23 avoids this precompile issue for me.

1 Like

A lower bound was added and this version was yanked from the registry. If you update you should be good. Sorry about that, the release just needed better lower bounds.

3 posts were split to a new topic: Error precompiling Differential Equations: in setfield!, expected LinearAlgebra.QRPivoted