Error in precompiling packages

Thanks. So if the same set of packagles were loaded with GARCH removed, it should work OK?
Could this be solved by
Removing GARCH and running a resolve?

This seems to improve the situation.

using Pkg
pkg"add" # This will uncap the dependencies of GARCH
1 Like

I’ll pass that on. Thanks so much!
[Update - it worked!]

If you give this version of Project.toml to your students it will work on Linux and Windows 10:

Project.toml (1.2 KB)

And if they try to install outdated packages like GARCH they will get an error message.

Thanks so much!

1 Like

As a more general comment, why are you not using the ARCHModels package which is very well maintained and (as far as I can tell) implements everything GARCH implements and lots more?

You are right, of course, and we are using ARCHModels, but these students are quite advanced and I encourage the more advanced ones to find the necessary packages. Like me, they obviously must have tested/rejected GARCH before finding ARCHModels (as the name seemed more obvious), but hadn’t thought it necessary to remove the unused package. Thank you for the suggestion, though.