Error building PyCall in 0.7.0

Hi,
following the 0.6.4 -> 1.0 route, today I’ve tried to install 0.7 on my ubuntu mate 16.04 box. Needless to say, everything was working fine before doing that.
The fact is that installation went ok, but problems arised when tried to install PyPlot, which failed at a very early stage because the PyCall package couldn’t install.
In the end I tried to install PyCall at the pkg> prompt,
issuing first the
ENV[“PYTHON”]=""
sentence first. I then got the following lines

Cloning default registries into /home/mazzanti/.julia/registries
Cloning registry General from “https://github.com/JuliaRegistries/General.git
Updating registry at ~/.julia/registries/General
Updating git-repo https://github.com/JuliaRegistries/General.git
Resolving package versions…
Installed Conda ────────── v1.0.1
Installed JSON ─────────── v0.19.0
Installed VersionParsing ─ v1.1.2
Installed MacroTools ───── v0.4.4
Installed Compat ───────── v1.1.0
Installed PyCall ───────── v1.18.3
Updating ~/.julia/environments/v0.7/Project.toml
[438e738f] + PyCall v1.18.3
Updating ~/.julia/environments/v0.7/Manifest.toml
[34da2185] + Compat v1.1.0
[8f4d0f93] + Conda v1.0.1
[682c06a0] + JSON v0.19.0
[1914dd2f] + MacroTools v0.4.4
[438e738f] + PyCall v1.18.3
[81def892] + VersionParsing v1.1.2
[2a0f44e3] + Base64
[ade2ca70] + Dates
[8bb1440f] + DelimitedFiles
[8ba89e20] + Distributed
[b77e0a4c] + InteractiveUtils
[76f85450] + LibGit2
[8f399da3] + Libdl
[37e2e46d] + LinearAlgebra
[56ddb016] + Logging
[d6f4376e] + Markdown
[a63ad114] + Mmap
[44cfe95a] + Pkg
[de0858da] + Printf
[3fa0cd96] + REPL
[9a3f8284] + Random
[ea8e919c] + SHA
[9e88b42a] + Serialization
[1a1011a3] + SharedArrays
[6462fe0b] + Sockets
[2f01184e] + SparseArrays
[10745b16] + Statistics
[8dfed614] + Test
[cf7118a7] + UUIDs
[4ec0a83e] + Unicode
Building Conda ─→ ~/.julia/packages/Conda/m7vem/deps/build.log
Building PyCall → ~/.julia/packages/PyCall/GQHil/deps/build.log
┌ Error: Error building PyCall:
│ ┌ Info: Using the Python distribution in the Conda package by default.
│ └ To use a different Python version, set ENV[“PYTHON”]=“pythoncommand” and re-run Pkg.build(“PyCall”).
│ [ Info: Downloading miniconda installer …
│ ERROR: LoadError: IOError: could not spawn curl -g -L -f -o /home/mazzanti/.julia/packages/Conda/m7vem/deps/usr/installer.sh https://repo.continuum.io/miniconda/Miniconda3-latest-Linux-x86_64.sh: no such file or directory (ENOENT)
│ Stacktrace:
│ [1] _jl_spawn(::String, ::Array{String,1}, ::Cmd, ::Tuple{RawFD,RawFD,RawFD}) at ./process.jl:370
│ [2] (::getfield(Base, Symbol("##499#500")){Cmd})(::Tuple{RawFD,RawFD,RawFD}) at ./process.jl:512
│ [3] setup_stdio(::getfield(Base, Symbol("##499#500")){Cmd}, ::Tuple{RawFD,RawFD,RawFD}) at ./process.jl:493
│ [4] #_spawn#498(::Nothing, ::Function, ::Cmd, ::Tuple{RawFD,RawFD,RawFD}) at ./process.jl:511
│ [5] _spawn at ./process.jl:507 [inlined]
│ [6] #run#509(::Bool, ::Function, ::Cmd) at ./process.jl:669
│ [7] run at ./process.jl:668 [inlined]
│ [8] download(::String, ::String) at ./download.jl:48
│ [9] macro expansion at ./logging.jl:311 [inlined]
│ [10] _install_conda(::String, ::Bool) at /home/mazzanti/.julia/packages/Conda/m7vem/src/Conda.jl:146
│ [11] _install_conda(::String) at /home/mazzanti/.julia/packages/Conda/m7vem/src/Conda.jl:145
│ [12] runconda(::Cmd, ::String) at /home/mazzanti/.julia/packages/Conda/m7vem/src/Conda.jl:111
│ [13] add at /home/mazzanti/.julia/packages/Conda/m7vem/src/Conda.jl:174 [inlined] (repeats 2 times)
│ [14] top-level scope at logging.jl:312
│ [15] top-level scope at /home/mazzanti/.julia/packages/PyCall/GQHil/deps/build.jl:196
│ [16] include at ./boot.jl:317 [inlined]
│ [17] include_relative(::Module, ::String) at ./loading.jl:1038
│ [18] include(::Module, ::String) at ./sysimg.jl:29
│ [19] include(::String) at ./client.jl:398
│ [20] top-level scope at none:0
│ in expression starting at /home/mazzanti/.julia/packages/PyCall/GQHil/deps/build.jl:170

I started reading that and saw, at the beginning, the
ERROR: LoadError: IOError: could not spawn curl -g -L -f -o /home/mazzanti/.julia/packages/Conda/m7vem/deps/usr/installer.sh https://repo.continuum.io/miniconda/Miniconda3-latest-Linux-x86_64.sh: no such file or directory

line. Surprisingly, /home/mazzanti/.julia/packages/Conda/m7vem/deps/usr/ is there, but it is empty, so no installer.sh can be found. Of course then, the rest follows.

Has anybody experienced anything like this? How can it be solved? Is there an issue with PyCall/PyPlot in 0.7 that prevents installation?

Thanks for your help,

Ferran.

Ok, a similar problem trying to install IJulia… the same installer.sh not appearing anywhere :frowning: I see this 0.6.4 -> 1.0 path is not going to be easy…
Help welcomed please. At this stage I can no longer use julia…
Best,
Ferran.

Welcome! For output and code, wrap them in triple backticks (`) for formatting.

How are you installing julia? Is curl installed? Do you have other julia versions installed in parallel?

Oh, that was it… curl was missing and after installation, everything was solved. Thx :slight_smile:
Regarding your questions, I’ve been using julia on the same computer(s) since 0.4, and never had to install curl, so I guess that’s why I was a little bit at a loss.
Thx again for your help.
Best,
Ferran.