PyCall installation problems

Hi all, I posted the problem in the PyCall page but it really belongs here. Please look at https://github.com/JuliaPy/PyCall.jl/issues/742 where I have a problem installing PyCall.

I would appreciate any pointers on how to fix this.

It is firewall issue. You may have to contact your company’s network admin. Tell them the symptom in detail, then usually they will give you necessary environment variables to set.

1 Like

I tried it at home without the firewall, and that had the same problem.

So here is the output that demonstrates that Conda installs without errors but PyCall does not.

(v1.3) pkg> add Conda
  Updating registry at `C:\Users\euskuba\.julia\registries\General`
  Updating git-repo `https://github.com/JuliaRegistries/General.git`
 Resolving package versions...
 Installed ImageFiltering ─ v0.6.11
  Updating `C:\Users\euskuba\.julia\environments\v1.3\Project.toml`
 [no changes]
  Updating `C:\Users\euskuba\.julia\environments\v1.3\Manifest.toml`
  [6a3955dd] ↑ ImageFiltering v0.6.10 β‡’ v0.6.11

(v1.3) pkg> build Conda
  Building Conda β†’ `C:\Users\euskuba\.julia\packages\Conda\kLXeC\deps\build.log`

(v1.3) pkg> add PyCall
 Resolving package versions...
  Updating `C:\Users\euskuba\.julia\environments\v1.3\Project.toml`
 [no changes]
  Updating `C:\Users\euskuba\.julia\environments\v1.3\Manifest.toml`
 [no changes]

(v1.3) pkg> build PyCall
  Building Conda ─→ `C:\Users\euskuba\.julia\packages\Conda\kLXeC\deps\build.log`
  Building PyCall β†’ `C:\Users\euskuba\.julia\packages\PyCall\ttONZ\deps\build.log`
β”Œ Error: Error building `PyCall`:
β”‚ Collecting package metadata (current_repodata.json): ...working... failed
β”‚
β”‚ CondaHTTPError: HTTP 000 CONNECTION FAILED for url <https://repo.anaconda.com/pkgs/main/win-64/current_repodata.json>
β”‚ Elapsed: -
β”‚
β”‚ An HTTP error occurred when trying to retrieve this URL.
β”‚ HTTP errors are often intermittent, and a simple retry will get you on your way.
β”‚
β”‚ If your current network has https://www.anaconda.com blocked, please file
β”‚ a support request with your network engineering team.
β”‚
β”‚ 'https://repo.anaconda.com/pkgs/main/win-64'
β”‚
β”‚
β”‚ β”Œ Info: Using the Python distribution in the Conda package by default.
β”‚ β”” To use a different Python version, set ENV["PYTHON"]="pythoncommand" and re-run Pkg.build("PyCall").
β”‚ [ Info: Running `conda install -y numpy` in root environment
β”‚ ERROR: LoadError: failed process: Process(setenv(`'C:\Users\euskuba\.julia\conda\3\Scripts\conda.exe' install -y numpy`,["PATH=C:\\anaconda3;C:\\anaconda3\\bin;C:\\anaconda3\\condabin;C:\\ProgramData\\Oracle\\Java\\javapath;C:\\WINDOWS\\system32;C:\\WINDOWS;C:\\WINDOWS\\System32\\Wbem;C:\\WINDOWS\\System32\\WindowsPowerShell\\v1.0\\;C:\\Program Files\\Microsoft VS Code\\bin;C:\\Program Files\\Intel\\WiFi\\bin\\;C:\\Program Files\\Common Files\\Intel\\WirelessCommon\\;C:\\WINDOWS\\system32\\config\\systemprofile\\AppData\\Local\\Microsoft\\WindowsApps;C:\\Program Files (x86)\\Adaptiva\\AdaptivaClient\\bin\\x32;C:\\Program Files (x86)\\Adaptiva\\AdaptivaClient\\bin\\x64;C:\\WINDOWS\\system32;C:\\WINDOWS;C:\\WINDOWS\\System32\\Wbem;C:\\WINDOWS\\System32\\WindowsPowerShell\\v1.0\\;C:\\WINDOWS\\System32\\OpenSSH\\;C:\\Program Files\\PuTTY\\;C:\\Users\\euskuba\\AppData\\Local\\Microsoft\\WindowsApps;C:\\Users\\euskuba\\AppData\\Local\\Microsoft\\WindowsApps;C:\\Users\\euskuba\\AppData\\Local\\atom\\bin;C:\\Users\\euskuba\\.julia\\packages\\MKL\\9dWbC\\deps\\usr\\bin;C:\\Users\\euskuba\\.julia\\packages\\MKL\\9dWbC\\deps\\usr\\bin", "USERDOMAIN_ROAMINGPROFILE=ERICSSON", "HOMEPATH=\\", "ADAPTIVACLIENT=C:\\Program Files (x86)\\Adaptiva\\AdaptivaClient", "MKL_INTERFACE_LAYER=ILP64", "=K:=K:\\", "PATHEXT=.COM;.EXE;.BAT;.CMD;.VBS;.VBE;.JS;.JSE;.WSF;.WSH;.MSC", "SESSIONNAME=Console", "SYSTEMROOT=C:\\WINDOWS", "APPDATA=C:\\Users\\euskuba\\AppData\\Roaming"  …  "PROGRAMFILES=C:\\Program Files", "LOGONSERVER=\\\\USDOIWEGAD00001", "DRIVERDATA=C:\\Windows\\System32\\Drivers\\DriverData", "CONDA_PREFIX=C:\\Users\\euskuba\\.julia\\conda\\3", "FPS_BROWSER_USER_PROFILE_STRING=Default", "JULIA_LOAD_PATH=@;C:\\Users\\euskuba\\AppData\\Local\\Temp\\jl_62oMl4", "SYSTEMDRIVE=C:", "FPS_BROWSER_APP_PROFILE_STRING=Internet Explorer", "PROCESSOR_ARCHITECTURE=AMD64", "OPENBLAS_MAIN_FREE=1"]), ProcessExited(1)) [1]
β”‚
β”‚ Stacktrace:
β”‚  [1] pipeline_error at .\process.jl:525 [inlined]
β”‚  [2] #run#565(::Bool, ::typeof(run), ::Cmd) at .\process.jl:440
β”‚  [3] run at .\process.jl:438 [inlined]
β”‚  [4] runconda(::Cmd, ::String) at C:\Users\euskuba\.julia\packages\Conda\kLXeC\src\Conda.jl:113
β”‚  [5] #add#1(::String, ::typeof(Conda.add), ::String, ::String) at C:\Users\euskuba\.julia\packages\Conda\kLXeC\src\Conda.jl:184
β”‚  [6] add at C:\Users\euskuba\.julia\packages\Conda\kLXeC\src\Conda.jl:183 [inlined] (repeats 2 times)
β”‚  [7] top-level scope at C:\Users\euskuba\.julia\packages\PyCall\ttONZ\deps\build.jl:84
β”‚  [8] include at .\boot.jl:328 [inlined]
β”‚  [9] include_relative(::Module, ::String) at .\loading.jl:1105
β”‚  [10] include(::Module, ::String) at .\Base.jl:31
β”‚  [11] include(::String) at .\client.jl:424
β”‚  [12] top-level scope at none:5
β”‚ in expression starting at C:\Users\euskuba\.julia\packages\PyCall\ttONZ\deps\build.jl:43
β”” @ Pkg.Operations C:\Users\euskuba\AppData\Local\Julia-1.3.0\share\julia\stdlib\v1.3\Pkg\src\backwards_compatible_isolation.jl:649

(v1.3) pkg>

I am going to try installing Julia 1.3.1 to see if a clean install does the trick.

Try conda install numpy. I am pretty sure that it will fail for the same reason: somehow, access to conda repo (https://repo.anaconda.com/pkgs/main/win-64) is being blocked.

Network accessibility is not the problem. Problem clearly says that the target URL doesn’t contain the file current_repodata.json which the PyCall tries to call.
https://repo.anaconda.com/pkgs/main/win-64/current_repodata.json is not existing in the anaconda repo channel where as repodata.json file exits.

Question for me as well is, how to update this meta information?

I have the exact same problem. Have you solved it yet? Because, I can’t crack it.

I just went to the JuliaPro distribution and everything seems to work now.