Error building 'MPI`, libmpi could not be found

It looks like it is picking up an old libc. Perhaps try adding /cvmfs/soft.computecanada.ca/gentoo/2020/lib64 to your LD_LIBRARY_PATH?

@francispoulin I had a similar issue and I was wondering if you were able to build MPI?

Sorry for the late reply. I did try that and it didn’t help.

I am asking for support from people who maintain the machines and hope they can figure it out. I will let you know if/when we get it working.

Unfortunately, I have not had a successful build on the server. I’m asking for some technical support and if others manage to do it, I will certainly share waht I learn. Sorry that I could not be of more help.

Most of the time, messages like

fileX.so: cannot open shared object file: No such file or directory

are misleading, because it isn’t fileX.so that can’t be found, but some of its dependencies. All kernels are very bad because with this message they don’t tell you what can’t be found. On systems like Linux you have to use strace to find out what file is being searched but can’t be found. Nothing Julia can’t do about, operating systems are just unhelpful.

Thank you @giordano for the help. I have never used strace before. Could you point me to an example that might help me figure out what I need to do?

Start julia with

strace julia 2> strace.log

After you get the error message, you can see in the strace.log file what files are being searched. This file is going to be large, have fun.

You might also be able to use LD_DEBUG, which will output info from the linker. I think LD_DEBUG=libs julia should be sufficient?

1 Like

Thanks for your reply.

I have now figured it out and it worked.
I did not change any of other environmental variables but did the following

  1. go to a terminal
  2. type emacs ~/.julia/prefs/MPI.toml
  3. set path = “/usr/local/Cellar/open-mpi/4.1.1_2”

It seems that the way of setting the path is different from the ways in the two links in my original post (see Error building MPI---ERROR: LoadError: libmpi could not be found) which were in the files ~/.bash_profile or ~/.profile

Maybe it’s Julia version thing