Documenter: I'm not seeing the "link to source" buttons in my local docs build, how can I?

I’m building some docs locally, and I noticed that I do not have the “source” button appearing when I try to hover over docstrings in the docs. (See below for an image of such “source” buttons).

Does anyone know why I don’t see any of these “source” hover buttons? How might I can locally-build my docs to make sure they appear?

screenshot showing light blue source button in lower right hand corner

Here are the steps I’m taking.

  1. Download the repo
  2. Go to /docs/
  3. Activate the current environment, and instantiate it
  4. run make.jl
  5. Open up the generated file at /docs/build/index.html in an internet browser (e.g. Firefox)
  6. Go/navigate to a function docstring
  7. Try to hover mouse over the function docstring, and see if “source” button appears

Things I’ve tried:

  • I even confirmed in the HTML source code of the locally-generated docs pages that I do not have any mention of docs-sourcelink (the HTML class used for such elements in the docs).
  • I’ve updated to Documenter 0.27.5 but still the same behavior.
  • Tried to set prettyurls = true and rerun making the docs.
  • Tried to use LiveServer.jl to serve the docs on a local web server/port
  • Tried to search the Documenter.jl docs/source code for this, but didn’t find anything explaining how to locally build docs
  • Replicated the same sort of behavior when I try to locally build docs for Luxor.jl

I’m still not sure why this happens, and how I can build docs locally in a way that I can get the “source” buttons.

Here is an example link from Luxor showing that “source” button:{Any}

In that page, you will be able to find the following docs-sourcelink in the HTML:

<a class="docs-sourcelink" target="_blank" href="">source</a>