Docs failing to update. Can someone explain the error message

I pushed an update to SIAMFANLEquations.jl mainly to make the Project.toml file compatible with v1.11. One thing I also did was take the version number out of

Everything went well except the documenter update failed with this

ArgumentError: link `"v1.0" => "v1.0.1"` incompatible with link `"v1.0.0" => "v1.0"`.

I tried again today with the fix from here but got the same error. Any idea what could be causing this?

On the gh-pages branch you have a subfolder v1.0 with a symlink to v1.0.0. Normally it is the other way around: Documenter pushes to v1.0.0 and then symlinks v1.0 to it. I don’t know how you ended up with this state but the fix is to first remove the v1.0.0 symlink and then rename the folder v1.0 to v1.0.0.

I think I figured out how do to it, but when I try to get to my stable docs I see a banner on top that says

This documentation is not for the latest stable release, but for either the development version or an older release.
[Click here to go to the documentation for the latest stable release.](

The link takes me back to the same page. I used your vx.x.x-docs approach to do this. This time I did not get the complaint about 1.0 vs 1.0.0, so that part is working. I’m thinking that this is because the docs for v1.0.1 were not generated when Tagbot tagged the release, so the v1.0.1-docs directory is not referring to anything.

Would it break anything if I deleted the v1.0.1 tag and retagged that version?