Disable secret for pluto.jl notebook

Pluto-notebooks are launched in the default browser. If I want to open the notebook in a different browser, I have to copy the localhost adress from the terminal to include the nessecary secret. I however want to be able to copy the address from the URL-line, and I have no need for a secret passkey. Is there a way to disable the secret?

My attempt failed, and is does not seem like there is a key for this feature:

julia> using Pluto; Pluto.run(secret=false)
ERROR: ArgumentError: invalid key secret, possible keys are: root_url, host, port, launch_browser, dismiss_update_notification, show_file_system, notebook_path_suggestion, disable_writing_notebook_files... please check documentation for other valid keys
Stacktrace:
 [1] validate_keywords(::Type{Pluto.Configuration.Options}, keys::Vector{Symbol}; kw::Base.Iterators.Pairs{Symbol, Bool, Tuple{Symbol}, NamedTuple{(:secret,), Tuple{Bool}}})
   @ Configurations C:\Users\densb\.julia\packages\Configurations\S1RPp\src\parse.jl:288
 [2] #from_field_kwargs!#16
   @ C:\Users\densb\.julia\packages\Configurations\S1RPp\src\parse.jl:240 [inlined]
 [3] from_kwargs(convention!::typeof(Configurations.from_field_kwargs!), ::Type{Pluto.Configuration.Options}; kw::Base.Iterators.Pairs{Symbol, Bool, Tuple{Symbol}, NamedTuple{(:secret,), Tuple{Bool}}})
   @ Configurations C:\Users\densb\.julia\packages\Configurations\S1RPp\src\parse.jl:73
 [4] #from_field_kwargs#8
   @ C:\Users\densb\.julia\packages\Configurations\S1RPp\src\parse.jl:96 [inlined]
 [5] #from_flat_kwargs#11
   @ C:\Users\densb\.julia\packages\Pluto\yDJcG\src\Configuration.jl:117 [inlined]
 [6] #run#224
   @ C:\Users\densb\.julia\packages\Pluto\yDJcG\src\webserver\WebServer.jl:87 [inlined]
 [7] top-level scope
   @ REPL[1]:1

See last line of this file:

Are you saying that it is disabled by default?

No. In this Dockerfile, the secrets are disabled using this command:

Pluto.run(require_secret_for_open_links=false, require_secret_for_access=false)
2 Likes

Right. Thanks a lot.

I really feel like pluto is missing some documentation, supported by the fact that you had to go digging in a Dockerfile (Which I don’t even know what is) to find stuff like this. At the very least, these keys should be suggested in the error shown in the original post.