] dev "c:/path/pack" errors "could not find project file"


I have created a package, to be shared with colleagues (via a zip… I know…). Unpacked, the folder structure is


and the Project.toml is

name = "Lithe"
uuid = "fc63d2cd-8c42-4a5a-b72e-39d79328fe4b"
authors = ["Philippe Maincon <philippe.maincon@sintef.no>"]
version = "0.1.0"

AbaqusReader = "bc6b9049-e460-56d6-94b4-a597b2c0390d"
FileIO = "5789e2e9-d7fb-5bc7-8068-2c6fae9b9549"
GLMakie = "e9467ef8-e4e7-5192-8a1a-b1aee30e663a"
LinearAlgebra = "37e2e46d-f89d-539d-b4ee-838fcccc9c8e"
Logging = "56ddb016-857b-54e1-b83d-db4d58db5568"
Packaging = "fd63d2cd-8b42-4a5f-b92e-39d79428fe4b"
Printf = "de0858da-6303-5e67-8744-51eddeeeb8d7"
Ratios = "c84ed2f1-dad5-54f0-aa8e-dbefe2724439"
SparseArrays = "2f01184e-e22b-5df5-ae63-d93ebab69eaf"
SpecialFunctions = "276daf66-3868-5448-9aa4-cd146d93841b"
StaticArrays = "90137ffa-7385-5640-81b9-e52037218182"

julia = "1.6.0"

BenchmarkTools = "6e4b80f9-dd63-53aa-95a3-0cdb28fa8baf"
Debugger = "31a5f54b-26ea-5ae9-a837-f05ce5417438"
Documenter = "e30172f5-a6a5-5a46-863b-614d45cd2de4"
Logging = "56ddb016-857b-54e1-b83d-db4d58db5568"
Revise = "295af30f-e4ad-537b-8983-00126c2a3abe"
Test = "8dfed614-e22c-5e08-85e1-65c5234f0b40"

test = ["Test", "BenchmarkTools", "Debugger", "Documenter", "Logging", "Revise"]

I then try to open the package for development (on a “greenfield” computer) to prepare setup instructions for my package, but I get an error which I struggle to correct:

] dev "C:/.../Lithe/"
Error: could not find project file in package at "C:/.../Lithe/" maybe `subdir` needs to be specified

Does that ring any bells? Would a failure to parse Project.toml cause this error? Why don’t I get this error on my other (development) computer?

I tried the same installation on yet another computer and do not get said error. Confusion has been achieved!

Are both computers running windows? Do they have the same julia version (which version are you running)? Does the error also happen without those "?

Hi Sukera,

Good questions: both computers are running windows
A) Windows 10 21H1 on the “yet another” computer where things worked
B) Windows 7, with the latest update (which is one year old, ugh, vulnerability)
and in both cases I used Julia 1.6.3.

So the cause may very well be an old Window version.

Another hypothesis is that while A never has seen Julia before, I have had Julia installations on B, although I made every effort to clean that out for the present testing.

Hard to say! :smiley:

The error message indicates that the given path is an existing directory but that no Project.toml file is found there. Try to readdir() the same path that you gave to dev and see if that provides any clue. If it does find Project.toml but something is wrong with it you get different errors.

Given that you are on Windows I would investigate if there’s any possibility of lowercase/uppercase confusion among your filenames.

Hej Gunnar,

Tack så mycket - I’ll look into this (when I am back at my home computers).


Turns out, I actually managed to type in the wrong path. How :crazy_face: can I get??? Apologies to everyone involved.