DataFrames still not compile under Julia 0.7


#1

There is an error compiling DataArrays:

ERROR: LoadError: LoadError: UndefVarError: ipermute!! not defined

But it looks that DataArrays is not being worked on for quite some long time. Any chance DataFrames can work under 0.7 soon?


#2

It works for me.

julia> using DataFrames

julia> d = DataFrame()
0×0 DataFrame

julia> versioninfo()
Julia Version 0.7.0
Commit a4cb80f3ed (2018-08-08 06:46 UTC)
Platform Info:
  OS: Linux (x86_64-pc-linux-gnu)
  CPU: Intel(R) Core(TM) i7-4810MQ CPU @ 2.80GHz
  WORD_SIZE: 64
  LIBM: libopenlibm
  LLVM: libLLVM-6.0.0 (ORCJIT, haswell)
(v0.7) pkg> status
    Status `~/.julia/environments/v0.7/Project.toml`
  [a93c6f00] DataFrames v0.13.0

Do you have the same versions?


#3

Hi, thanks very much.

I deleted .julia folder and re-added packages, and now it works.

I guess I was testing the 0.7-RC’s and got the packages then, which didn’t work. But I did do Pkg.update() under the new 0.7, but it didn’t help. So I had to remove all packages and re-install.