CxxWrap namespace rename



Hi all,

Following @SylvainCorlay 's work, we are thinking of splitting off the C++ part of CxxWrap into a separate C++ project. This would simplify things for e.g. Linux distributions, where the binaries could be distributed using the same compiler ecosystem as the rest of the distribution. It would also fit better with the BinDeps workflow, where Julia packages get the binary dependencies externally.

This raises the issue of the name of the C++ namespace and library, which is currently cxx_wrap, but from a C++ standpoint it would be more logical to refer to Julia somehow. So far, we’ve been kicking around the following:

  • jlbind
  • jlplus
  • juliaplus

Suggestions are welcome, it is the right time for a rename since preparing the package for the split required moving files around anyway. See also the related issue and discuss there if preferred.


This the list above, I vote for jlbind!