Crash when using GR

question

#1

I want to use GR.jl (with Plots.jl), but after installing it, using GR crashes the program. So fast, that I can’t read the error message. I use 0.5.0 on win10. Couldn’t find any useful info. I’m also new to Julia and couldn’t find any log files yet.
Can you help me out?


#2

You could start Julia from CMD, that way the window won’t close when the program does. Then post any error output.


#3

It says:
Unable to load GR framework runtime environment
C:\Users#BOSS.julia\v0.5\GR\src…\deps\gr\libGR.dll: No such file

(I know that the #BOSS is not the perfect username, but it didn’t worked in other account without any #).
Before trying using GR I always ran Pkg.update(), and sometime it generates GitError. If not, then says: No packages to install, update or remove


#4

In your case, the correct path (for the GR run-time) should be something like C:\Users#BOSS\.julia\v0.5\GR\deps\gr\libGR.dll. I have no idea, why there is a src\.. component in your path. There are also missing backslashes (typos?).

I’d suggest to re-build GR:

ENV["GRDIR"]=""
Pkg.build("GR")

If that doesn’t help, you probably have to remove and/or initialize your package environment (using Pkg.init()) and start from scratch …


#5

I reinstalled the whole Windows and didn’t help. On another PC it’s working just fine…
I also tried to remove, rebuild. initialize the package, and also nothing.
I searched through the GR folder and didn’t find libGR.dll in any folder.
Should I copy the missing files and folders from the other computer (also win10)?


#6

Did you Copy/Paste the path C:\Users#BOSS.julia\v0.5\GR\src..\deps\gr\libGR.dll ?

Do you have a similar username (with a # character) on the other PC (where it’s working)?


#7

I don’t understand what you mean by copy/paste. I searched in the file explorer the dll file and couldn’t find it (on that computer which doesn’t work). On the working PC everything is in it’s place.
Now on both PC-s are normal usernames (nothing special character).

Sorry, if I got you confused.


#8

In this post, there are two \ missing - this path can’t work. That’s why I asked how you put the error message into the text window …


#9

It was just copy/paste, so the two \ were missing in the Julia error message.
On the fresh install (on the same PC), I get the same error and the \ are not missing:

C:\Users\Lajos.julia\v0.5\GR\src…\deps\gr\libGR.dll: No such file
Now I reinstalled Julia completely (JuliaPro exactly) and had problem with installing the package, I link a printscreen.
https://goo.gl/WpAXme
I tried Pkg.build("GR") and Pkg.build(), but after them I had the same error as above.


#10

While trying to add, remove and update packages I got several times GitHub timeout errors. A friend advised me to turn off the firewall and add the package, and it worked. Also thank you for your help!