Could not load library "libopenlibm"


#1

I’ve started learning arrays and i have faced this weird problem while using norm function
could any one help me?


#2

What is the output of versioninfo()?


#3

I’m very sorry for may late reply
this is the result


#4

I assume you installed Julia from binaries? Do you get the same error if you run that code from the Julia console?


#5

yes, i did it from binaries.
yes, still the same error :frowning:


#6

How about versioninfo(true) and show(readdir(JULIA_HOME)) ?

If the latter shows a libopenlibm.dll present, then could you download Dependency Walker http://www.dependencywalker.com/ and take a screenshot of the result when you open the libopenlibm.dll file in Dependency Walker?


#7

This is the result:


#8


#9


#10

file libopenlibm is there in julia files, but when i saw this error for first time i told my friend then, he gave me this file from his own julia file and i replace my file with his file , but the problem still there . and i posted the problem here.
i tried Dependency Walker for double check but he gave me an error.

small note: i replied with 4 replies because julia doesn’t allow me to add more than 3 images in one reply.


#11

Please reply with text in the future, images are not searchable if anyone else has the same issue.

Replacing openlibm.dll from your friend’s copy of Julia was a bad idea, as they most likely had a 64 bit copy of Julia. Reinstall Julia on your system without modifying any of the included files.


#12

I will try reinstall julia
Thanks alot :green_heart::blue_heart: