Changing to a different macOS Terminal for Julia

I just discovered Julia 2 days ago and started the Academy class this afternoon. I see that the REPL defaults to the standard Mac Terminal which is OK, but I also found the WARP Terminal that I am interested in exploring.

I was wondering if it would be possible to have Julia to open WARP rather than the Mac Terminal and how I would go about it? I would appreciate your help and advice in this.


Hi! Are you double-clicking the Julia Finder icon to start? That’s one way to start Julia, but many people would probably just open the terminal first, then type julia to start a Julia session. (For that to work, you might need to add some PATH details - see Platform Specific Instructions for Official Binaries for more.

Edit: I checked the Julia installation instructions using the Warp terminal and a standard install. It works as expected on MacOS Ventura:

(I remember Warp from last year - I opened an issue about font rendering… :))


Howdy Cormullion,
I have done both. I even tried it from Warp but it went to the Mac Terminal. I was afraid that PATH may end up in there somewhere.

Take a look at this:

I used to do this, although I prefer nowadays to manage my julia installs through juliaup and launch julia from my preferred terminal as cormullion suggests.


That might work, if Warp is Apple-scriptable. If it isn’t, you won’t be able to script it directly… (I would test it, but you have to sign up before you can use it… :scream::joy:).

1 Like

When I say done both, I meant that I went to the Applications directory and used the open command.
As of now, and I do not know if it is because of all the security changes that Apple has made over the past 2 years, but none of the recommended path changes will work for me. I am considering deleting the application and going the Homebrew route and seeing if that will let me go the terminal route, but then again I do not know if I will be able to alter which terminal that I use. I think that Homebrew is the same as juliaup that @aramirezreyes mentioned (do you just call it from your preferred terminal or did you make changes some how?)

As a heads up. I recently saw a thread that the homebrew builds do not work and should be removed. Juliaup on the other hand just pulls up the official binaries so it works just fine.

Yeah, that goes back and forth a lot. Mine is up and running right now (Version 1.8.5) on the Warp terminal. If I run into problems, I will run a brew uninstall and go your route. As it sits now, this appears to be the solution that I needed.

Anyway, it was about time that I updated other brew related items that I had for orthographics for X-Plane.

It seems like the homebrew build can silently fail and/or give incorrect results. Check for example this Twitter thread so keep that in mind. Maybe other users can chime in.

@aramirezreyes I do appreciate your concerns
However, but I have had success in other Homebrew installations for several years in the past and they have never given me any of those mystery failures.

Note: tweet is almost a year old. Then there is something odd about something that just suddenly, out of nowhere starts, to become a bad actor, it does not sound right. That being said, if indeed there was a root cause, there could have been a bug in the Julia code itself and a Julia revision had been created by the folks**

There are people who simply do not like Homebrew just like there are people who do not like Apple regardless and who will report/support any negative with no fact checks, but yes, there have been fails. Then again Github has had fails also. All that I am saying, one has to take things with a grain of salt.

**Of course Homebrew will not notify you about updates to a program unless you choose to run some brew commands periodically; and Homebrew gets the update/revision packages into their system.

Finally, I resorted to Homebrew because I could not get a path change command line to work 2 nights ago for some reason. I had copied it directly from the website. Then after consulting with some Apple Wizards. I uninstalled Homebrew and reinstalled the application and was successful with the command line am using either the Mac Terminal or the Warp Terminal now, so all is well.

The bonus is that I have updated a lot of Homebrew dependencies.

And have made some new friends to boot!!!

Well I am back again seeing as how it has been a while. Julia is in version 1.9.0. I can still call it from the Warp terminal. However double clicking the Julia application continues to open the macOS terminal. Perhaps it is something to bring up in Git?

1 Like

Welcome back!

One way you might be able to do this is to set the default application for the Unix executable files to be your preferred terminal. This involves no changes to the Julia script or to the Warp terminal’s settings.

In the Finder, open the Julia application package, and find the Julia binary. Then Ctrl>Always Open With should display some applications. You might have to search for the item, because (presumably) it hasn’t yet become a fully compatible MacOS application.

You can also do this using the Finder’s Get Info window.

(This shouldn’t break anything on your system, but S(disclaimer) :wink: )

1 Like

Thank you for your reply, alas, that did not seem to work. Warp opens but that is as far as it goes (or as far as my limited brain gets it to go), and I did not see the option in GET INFO:

Oh… Can you try to configure your system in the same way but set it to open iTerm, Kitty, Hyper, or any other terminal you have installed? If it works for any or most or all of them, then it might be the which is deficient here.

Good idea.
I downloaded iTerm2.

That worked better. It looked different from the start in that it was listed immediately under the terminal application. It started Julia when I selected it, so I had to go through the select as default and find it process and then Julia would start in iTerm when I double clicked the Julia application. It looks like there is something that Warp needs to work on.