Can't use any packages on v1.0 on mac osX

I have installed julia v1.0 as soon as I get to know about it. But now I can’t use any packages. Here is the error message for Plots. Similar error message is showing for all other packages.

julia> using Plots
[ Info: Precompiling Plots [91a5bcdd-55d7-5caf-9e0b-520d859cae80]
ERROR: LoadError: LoadError: UndefVarError: endof not defined
 [1] getproperty(::Module, ::Symbol) at ./sysimg.jl:13
 [2] top-level scope at none:0
 [3] include at ./boot.jl:317 [inlined]
 [4] include_relative(::Module, ::String) at ./loading.jl:1038
 [5] include at ./sysimg.jl:29 [inlined]
 [6] include(::String) at /Users/Abacus/.julia/packages/Plots/mqUvK/src/Plots.jl:3
 [7] top-level scope at none:0
 [8] include at ./boot.jl:317 [inlined]
 [9] include_relative(::Module, ::String) at ./loading.jl:1038
 [10] include(::Module, ::String) at ./sysimg.jl:29
 [11] top-level scope at none:2
 [12] eval at ./boot.jl:319 [inlined]
 [13] eval(::Expr) at ./client.jl:389
 [14] top-level scope at ./none:3
in expression starting at /Users/Abacus/.julia/packages/Plots/mqUvK/src/types.jl:90
in expression starting at /Users/Abacus/.julia/packages/Plots/mqUvK/src/Plots.jl:156
ERROR: Failed to precompile Plots [91a5bcdd-55d7-5caf-9e0b-520d859cae80] to /Users/Abacus/.julia/compiled/v1.0/Plots/ld3vC.ji.
 [1] error(::String) at ./error.jl:33
 [2] macro expansion at ./logging.jl:313 [inlined]
 [3] compilecache(::Base.PkgId, ::String) at ./loading.jl:1184
 [4] _require(::Base.PkgId) at ./logging.jl:311
 [5] require(::Base.PkgId) at ./loading.jl:852
 [6] macro expansion at ./logging.jl:311 [inlined]
 [7] require(::Module, ::Symbol) at ./loading.jl:834

Many packages are in the progress of getting upgraded to 1.0. Plots should be ready very soon.

Aren’t 0.7 and 1.0 essentially the same? Plots etc work with 0.7, why not 1.0?

The usual culprit is that some packages extend deprecated functions which still exist on 0.7 (so that you can get the deprecation warnings) but are gone on 1.0. If we’d had the ability to warn about extending deprecated functions we could have warned about this but we don’t have that capability so there were no warnings about it.

Ok, thanks!

@iArchimedes: Just use 0.7 right now if you want to use packages. Using 1.0 will not be helpful since the failing packages won’t have meaningful error messages.

@tobias.knopp: When julia 1.0 will be ready for packages?

you have to state this the other way around. When are packages ready for Julia 1.0. And that depends on each package individually. But even then you can safely use 0.7 instead of 1.0. Thats the point: Using 0.7 has no downside compared to 1.0 (at least for now until 1.0.1 is released)

Great, Thanks!