Can't install PkgDev - Julia ^1.0.1


#1

Hi all,

I’s just finalized a new package that I’d like to publish but I’m unable to install PkgDev on Julia 1.0.1 or 1.0.2, see below error message.

(v1.0) pkg> add PkgDev
  Updating registry at `~/.julia/registries/General`
  Updating git-repo `https://github.com/JuliaRegistries/General.git`
 Resolving package versions...
ERROR: Unsatisfiable requirements detected for package PkgDev [149e707d]:
 PkgDev [149e707d] log:
 ├─possible versions are: [0.1.0-0.1.6, 0.2.0-0.2.1] or uninstalled
 ├─restricted to versions * by an explicit requirement, leaving only versions [0.1.0-0.1.6, 0.2.0-0.2.1]
 └─restricted by julia compatibility requirements to versions: uninstalled — no versions left

Would anyone have an idea abut what to do?
Is there any alternative to PkgDev if that happens to be impossible to install?


#2

For package registration, use attobot, for generation, consider


#3

Thanks!
I was actually just reading about Attobot but seem to work with GitHub only while my project is hosted on GitLab.

Has anyone had it working with GitLab?
Or is it that Julia Package must be hosted on GiHub (as fas as Attobot is concerned)?


#4

Currently, I think yes. Just mirror the repo.


#5

That’s indeed the easiest work around, thanks


#6

For the record issue is known to PkgDev devs