Cannot Install JuliaDB

I am trying to install JuliaDB so I can start learning how to use databases in Juila.

I am having a conflict with StatsBase. If I understand the error message correctly, JuliaDB requires version 0.13.1 or earlier of StatsBase, but only versions 0.24.0 to 0.33.2 are available?

I’ve tried:
pkg> update, which didn’t solve the issue.

I’ve tried:
using Pkg
Pkg.develop(“StatsBase”)
Pkg.add(“JuliaDB”), which didn’t solve the issue

and I’ve tried:
using Pkg
Pkg.rm(“StatsBase”)
Pkg.add(“JuliaDB”), which also didn’t solve the issue.

The error code is always a little different, but always includes “unsatisfiable requirements” between JuliaDB and StatsBase. After removing StatsBase and trying to add JuliaDB, I got the error message below.

Any help would be much appreciated! If JuliaDB isn’t the right package to use for making databases, recommendations on the most current packages would be much appreciated as well.

julia> Pkg.add(“JuliaDB”)
Resolving package versions…
ERROR: Unsatisfiable requirements detected for package StatsBase [2913bbd2]:
StatsBase [2913bbd2] log:
├─possible versions are: [0.24.0, 0.25.0, 0.26.0, 0.27.0, 0.28.0-0.28.1, 0.29.0, 0.30.0, 0.31.0, 0.32.0-0.32.2, 0.33.0-0.33.2] or uninstalled
├─restricted by compatibility requirements with LsqFit [2fda8390] to versions: [0.32.0-0.32.2, 0.33.0-0.33.2]
│ └─LsqFit [2fda8390] log:
│ ├─possible versions are: [0.5.0, 0.6.0, 0.7.0-0.7.3, 0.8.0-0.8.1, 0.9.0, 0.10.0, 0.11.0, 0.12.0] or uninstalled
│ └─restricted to versions 0.12.0 by an explicit requirement, leaving only versions 0.12.0
├─restricted by compatibility requirements with PGFPlots [3b7a836e] to versions: 0.33.0-0.33.2
│ └─PGFPlots [3b7a836e] log:
│ ├─possible versions are: [3.0.0-3.0.3, 3.1.1-3.1.3, 3.2.0-3.2.1, 3.3.0-3.3.4] or uninstalled
│ └─restricted to versions 3.3.4 by an explicit requirement, leaving only versions 3.3.4
└─restricted by compatibility requirements with JuliaDB [a93385a2] to versions: [0.24.0, 0.25.0, 0.26.0, 0.27.0, 0.28.0-0.28.1, 0.29.0, 0.30.0, 0.31.0, 0.32.0-0.32.2] — no versions left
└─JuliaDB [a93385a2] log:
├─possible versions are: [0.9.0, 0.10.0, 0.11.0-0.11.2, 0.12.0, 0.13.0-0.13.1] or uninstalled
└─restricted to versions * by an explicit requirement, leaving only versions [0.9.0, 0.10.0, 0.11.0-0.11.2, 0.12.0, 0.13.0-0.13.1]

The reason is different:

  • LsqFit requires 0.32-0.33
  • JuliaDB requires 0.32
  • PGFPlots requires 0.33

So you have package conflict between JuliaDB and PGFPlots. It looks like JuliaDB is too restrictive, so If you can avoid using PGFPlots you’ll be fine. One way is to remove PGFPlots.jl, but it is better to create a separate clean environment. To do it, you can create a new directory and inside that directory, you can do

# Switch to Pkg mode
julia> ]
pkg> activate .
pkg> add StatsBase
pkg> add JuliaDB

and everything should be installed without problem.

Also, it makes sense to open an issue in JuliaDB, maybe these restrictions can be lifted.