Cannot install julia-client@0.8.10 in atom using uber-juno

Same here, I can’t find any solution.

Can you give more details on your OS as well as the output of atom -v in a terminal?

I am not on my computer right now. The only thing I know is that it’s a W10 64bits. It worked very well for the last 5 days and this afternoon my code just wouldn’t run anymore (with the standard Ctrl Shift Enter)

If I understand my error msg correctly it basically says that it can’t find the Python executable at the given location despite the fact that it actually is ! Jupiter Notebook has no issue finding it for instance.
I’ll be more detailed once back home.

I had the same problem when updating atom to 1.39.0, 1.40.0beta didn’t work either.

I needed to go back to atom 1.38.2 and rebuild the package julia-client to make it work.

I’m on OSX 10.14.5

For me :
Atom : 1.39.0
Electron: 3.1.10
Chrome : 66.0.3359.181
Node : 10.2.0

My julia-client works until I upgraded to the new Atom release, 1.39.0. After upgrade, Atom says that the package needs a rebuild. And there is also some error during the rebuilding process.
My computer is Win10.

Atom uses python 2, so it will not work if the python is python 3. However, even I use python 2, I still have issues with the julia-client package and the new Atom.

Then why did it work for 5 days before it crashed ? I had the very same version of Python

I had the same issue: updated atom to 1.39.0, then it wanted to update julia-client@0.8.10, and since then I cant get it working (Windows 10).

When I tried to clean install Atom (I had to delete folders in addition to the remove programs tool), it reinstalled all packages again except julia-client. But this time I got this message:

Please check your internet connection, or report this to
and we’ll try to help.
Error: Installing “julia-client@0.8.10” failed.

But my internet is fine (I can post to this forum), and the link they sent to report is broken.

Any help greatly appreciated!!

Same problem here (on MacOs 10.14).
Juno stopped working after atom updated to 1.39.
Version 1.38.2 (disable auto-updates!) seem to be the latest working version.

Because when Atom is not upgraded, the julia-client is installed from pre-compiled binary files. And for the new release of Atom 1.39, the pre-compiled binary julia-client seems to have some incompatibility problems, so rebuild (recompile) from source is needed and so is python. This is when you have the python 2 vs 3 problem.

Oh ok. Well I’ve tried to download Python 2.7, I modified the PYTHON env variable consequently. Indeed the error message concerning Python disappeared but the rest remains.
General error : Installing “julia-client@0.8.10” failed.
And when I try to install (via settings->install) julia-client, that’s the begginning of the message :

node-pty-prebuilt@0.7.6 install C:\Users\YLANNR~1\AppData\Local\Temp\apm-install-dir-119624-12452-wyanc8.70upm\node_modules\julia-client\node_modules\node-pty-prebuilt
prebuild-install || node scripts/install.js

C:\Users\YLANNR~1\AppData\Local\Temp\apm-install-dir-119624-12452-wyanc8.70upm\node_modules\julia-client\node_modules\node-pty-prebuilt>if not defined npm_config_node_gyp (node “C:\Users\Ylann Rouzaire\AppData\Local\atom\app-1.39.0\resources\app\apm\node_modules\npm\node_modules\npm-lifecycle\node-gyp-bin\…\node_modules\node-gyp\bin\node-gyp.js” rebuild --build_v8_with_gn=false ) else (node “C:\Users\Ylann Rouzaire\AppData\Local\atom\app-1.39.0\resources\app\apm\node_modules\npm\node_modules\node-gyp\bin\node-gyp.js” rebuild --build_v8_with_gn=false )
Génération des projets individuellement dans cette solution. Pour activer la génération en parallèle, ajoutez le commutateur “/m”.
C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V140\Platforms\x64\PlatformToolsets\v140\Toolset.targets(36,5): error MSB8036: The Windows SDK version 8.1 was not found. Install the required version of Windows SDK or change the SDK version in the project property pages or by right-clicking the solution and selecting “Retarget solution”. [C:\Users\Ylann Rouzaire\AppData\Local\Temp\apm-install-dir-119624-12452-wyanc8.70upm\node_modules\julia-client\node_modules\node-pty-prebuilt\build\deps\winpty\src\winpty-agent.vcxproj]
C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V140\Platforms\x64\PlatformToolsets\v140\Toolset.targets(36,5): error MSB8036: The Windows SDK version 8.1 was not found. Install the required version of Windows SDK or change the SDK version in the project property pages or by right-clicking the solution and selecting “Retarget solution”. [C:\Users\Ylann Rouzaire\AppData\Local\Temp\apm-install-dir-119624-12452-wyanc8.70upm\node_modules\julia-client\node_modules\node-pty-prebuilt\build\deps\winpty\src\winpty.vcxproj]

npm WARN deprecated coffee-script@1.12.7: CoffeeScript on NPM has moved to “coffeescript” (no hyphen)
prebuild-install WARN install No prebuilt binaries found (target=3.1.10 runtime=electron arch=x64 libc= platform=win32)
gyp ERR! build error
gyp ERR! stack Error: C:\Program Files (x86)\MSBuild\14.0\bin\msbuild.exe failed with exit code: 1
gyp ERR! stack at ChildProcess.onExit (C:\Users\Ylann Rouzaire\AppData\Local\atom\app-1.39.0\resources\app\apm\node_modules\npm\node_modules\node-gyp\lib\build.js:262:23)
gyp ERR! stack at emitTwo (events.js:126:13)
gyp ERR! stack at ChildProcess.emit (events.js:214:7)
gyp ERR! stack at Process.ChildProcess._handle.onexit (internal/child_process.js:198:12)
gyp ERR! System Windows_NT 10.0.17134
gyp ERR! command “C:\Users\Ylann Rouzaire\AppData\Local\atom\app-1.39.0\resources\app\apm\bin\node.exe” “C:\Users\Ylann Rouzaire\AppData\Local\atom\app-1.39.0\resources\app\apm\node_modules\npm\node_modules\node-gyp\bin\node-gyp.js” “rebuild” “–build_v8_with_gn=false”
gyp ERR! cwd C:\Users\YLANNR~1\AppData\Local\Temp\apm-install-dir-119624-12452-wyanc8.70upm\node_modules\julia-client\node_modules\node-pty-prebuilt
gyp ERR! node -v v8.9.3
gyp ERR! node-gyp -v v3.7.0
gyp ERR! not ok
npm WARN enoent ENOENT: no such file or directory, open ‘C:\Users\YLANNR~1\AppData\Local\Temp\apm-install-dir-119624-12452-wyanc8.70upm\package.json’
npm WARN apm-install-dir-119624-12452-wyanc8.70upm No description
npm WARN apm-install-dir-119624-12452-wyanc8.70upm No repository field.
npm WARN apm-install-dir-119624-12452-wyanc8.70upm No README data
npm WARN apm-install-dir-119624-12452-wyanc8.70upm No license field.

The error message says that Windows SDK version 8,1 is needed, which I think is for Win8 originally. So one solution is to install the SDK and retry, and it may work.
I have a very similar problem, and have gone through python 3->python 2 and a similar Win SDK issue. But some other new problems appear… And I finally decide to go back to Atom 1.38.2, which works ok for me.

How did you downgrade ? I guess I have to download “” but then, where do I have to put these files ? I’m a bit lost because the filenames do not look like the ones I currently have with Atom 1.39.0 .
Thank you in advance !

You can download the zip and unpack it whereever you want. When you start the atom.exe, it will use your custom settings and your packages.
When the bug is fixed, you can later switch back to your original atom installation and delete the v38.2.

Please give julia-client v0.8.12-alpha a go, that should definitely fix the issue on Windows and Linux, but I’m not 100% that it works on MacOS as well.


After installing it Atom crashes upon every attempt to launch

EDIT: I’m using Mac OS Catalina Beta

1 Like

I did nothing and can inform that for me Atom on Windows 10 with Julia is working again. Thanks!

Same here (W10), when reinstalling everything it’s working ! Julia-client has been updated. Thank you !

Amazing! Atom w/ Julia works again. :grinning:
Thank you so much!