Build Error on Linux : template errors on commit 00b7b606d82c36461d448a2a7b59475235199acf

question

#1

Hello,

I’m getting many C++ template related errors while building at commit 00b7b606d82c36461d448a2a7b59475235199acf.

Here’s the link to the output.

I tried this on Ubuntu 14.04 x86_64 using local LLVM ( with Polly ) build. It had built successfully a few weeks back within the same environment.

Please help to resolve this and also let me know if I should add this as an issue to the GitHub repo.

Thank You,
Sanjay Srivallabh


Build Error on Linux : llvm/ExecutionEngine/Orc/ObjectLinkingLayer.h: No such file or directory
Build Error on Linux : llvm/ExecutionEngine/Orc/ObjectLinkingLayer.h: No such file or directory
#2

If you are trying to build with USE_POLLY=1, I don’t think that is regularly tested so may require updates. It will also require LLVM_VER=svn, which may require manual steps to clean and update LLVM in an existing build. (such as cleaning the llvm build directory)


#3

I had the same result when re-building after making USE_POLLY:=0 and then make clean. So, is it still dependent on Polly ?

Also, the error seems to be from parts that aren’t related to Polly. Please correct me if I’m wrong.

Thank You,
Sanjay Srivallabh


#4

You’ll have to make sure that the LLVM is entirely clean since otherwise you have a lot of artifacts lying around in the build tree.


#5

Hello Stefan,

What did you mean by LLVM build being clean ?


#6

You need to run make -C deps distclean-llvm since make clean doesn’t touch dependencies.


#7

Fixed by https://github.com/JuliaLang/julia/pull/20823, you are picking up the renamed header from your system llvm (or whatever other llvm version it can find).


Build Error on Linux : llvm/ExecutionEngine/Orc/ObjectLinkingLayer.h: No such file or directory