Bug: Memory leak at startup?

Dear all,

since a few days, I have some problems with using the “Julia Language Pack” within VCCode.

Having the Extension enabled (Screenshot 1) starts to consume an unusual amount of memory. Moreover, it becomes impossible to run a script by clicking the small rightward-pointing arrow in the top right of the heading line, which usually executes the current script in the current REPL.

Disabling the Extension (including restarting VSC in order to make sure it really is diabled) leads to no such problem (Screenshot 2).

Without the extension, I can however use Julia normally when starting just from the command line (Screenshot 3). I have now been using VSCode and Julia like this, however the convenient One-Mouse-Button start of a script was quite convenient for debugging. Moreover, I really miss the plotting window, which stored all previous plots within a session and which hence made analysis very comfortable by being able to jump between several plots.

I tried already uninstalling and reinstallaing the extension to no success. Also switching to the pre-release version did not solve the problem.
Anyone else has this issue?

Best regards.

1 Like

So does this happen from just starting vscode with a julia project, or is it when you try to run some code?

Do you see anything interesting from the various outputs related to the julia plugin? You can find the output tab next to the problems and terminals tabs in the bottom part of the screen, there you can then choose which output you want to see and there should be some with the name julia in them.

Thank you for your reply.
Yes, this appears without starting any code. Simply opening VSC and when I click on the “Enable” button within the Julia extension the memory starts to fill. Until I had this problem the extension was enabled automatically, so I did not explicitly press the button each time when opening VSC.

Thank you for pointing out the “outputs”-tab, I didnt look there yet. In the various outputs there are all kinds of information. Here is some which I figured might be problematic, but to be honest, I’m not exactly sure what to look out for:

  • Under “Julia language server”:
Activating project at `c:\Users\[Removed for privacy]\.vscode\extensions\julialang.language-julia-1.38.2\scripts\environments\languageserver\v1.8`

[ Info: Starting the Julia Language Server

[ Info: Symbol server store is at 'c:\Users\work\AppData\Roaming\Code\User\globalStorage\julialang.language-julia\symbolstorev5'.

[ Info: Starting LS at 1680362859

[Here are some more info messages, just like the next one:]

[ Info: Downloading caches...

┌ Info: Couldn't retrieve cache file for Polynomials.

└ exception = HTTP/1.1 404 Not Found while requesting https://www.julia-vscode.org/symbolcache/store/v1/packages/P/Polynomials_f27b6e38-b328-58d1-80ce-0feddd5e7a45/v3.2.3_c687954bd0b4b0508249fd36999f1b82456c2a10.tar.gz

[ Info: All cache files downloaded.

[ Info: Loading CSV from cache...

Maybe it is stuck trying to load the CSV package?

  • Under the output “Window” there is:
2023-04-02 00:33:41.943 [warning] Via 'product.json#extensionEnabledApiProposals' extension 'ms-toolsai.jupyter' wants API proposal 'notebookControllerKind' but that proposal DOES NOT EXIST. Likely, the proposal has been finalized (check 'vscode.d.ts') or was abandoned.
2023-04-02 00:33:45.245 [info] [perf] Render performance baseline is 37ms
2023-04-02 00:34:04.007 [error] [Extension Host] (node:15596) DeprecationWarning: uuidv4() is deprecated. Use v4() from the uuid module instead.
(Use `Code --trace-deprecation ...` to show where the warning was created)

There are some additional [warnings] above, but with similar messages, so I only copied the last one.

I will try to uninstall the CSV package tomorrow (It’s already past midnight here in Japan). However I would have expected that it might only lead to problems when actively loaded?? Maybe there are other messages to look out for for?

I appreciate any help.

1 Like

Don’t really know either, my guess would be either some borked compilation, in which case you could try to delete e.g. the compiled folder in your .julia folder.
Or maybe just really slow first load bases on windows filesystem and virus scanner making it take ages, have you tried to let it sit for a while and see if it gets past the load csv cache? Not using julia on windows much myself so mostly heard from others that this can be worse when downloading/compiling.

Try deleting c:\Users\work\AppData\Roaming\Code\User\globalStorage\julialang.language-julia\symbolstorev5. There’s an issue with the symbol cache files getting corrupted, which I haven’t yet been able to consistently repro. A possible symptom for that is absurd memory/CPU usage during deserialization.


@albheim: I have tried letting it sit for a while, but at some point the screen of the VSC window PC becomes dark and freezes, and a “out of memory” warning of windows appears which allows me to shut down the application. I have tried waiting for maybe about 20 minutes, but noting changed. Maybe I can try to wait even longer next time, but I assume I would need to wait each time on startup, which seems unpractical.

@pfizseb: Thank you for this suggestion. I did what you said, but unfortunately to no success. I actually tried to delete the folder while VSC was running, and could do so apart from a single file, which was used by VSC. Hence I could identify the assumingly stuck file, but after deleting this very file and restarting VSC, it simply got stuck at another file. This seems to happen generally, hence my original idea to uninstall the CSV package did not help.

I think I will open an issue at the julia-vscode github page.

1 Like