BinaryProvider options to curl or wget

#1

Putting my money where my mouth is I am trying to build a tarball of ffmeg on an ARM 64 system.
BinaryProvider finds curl as its first download engine.
As I am behind a proxy I then get
[09:28:40] curl: (60) SSL certificate problem: self signed certificate in certificate chain
How can I feed this option to curl: curl -k

I can define wget as the first binary provider using an ENV variable.
But similarly how do I feed it a parameter of --no-check-certificate

#2

Answering my own question I think alias curl=“curl -k” might do the trick

#3

Yeah, we don’t really support passing arbitrary parameters like that (EDIT: I should say we could, and I’m not opposed to it, but in this particular instance, I’m not sure it’s the proper fix). I consider this solution to be rather wildly insecure; have you not installed your proxy’s root certificates into your system’s certificate store?