Basic questions for migrating a script to 0.7


#1

Hi all,

I have a private package located at /home/jock/repos/private/MyPkg.jl.
Among other things it contains scripts/backtest, which is executable.
It looks like this:

#! /usr/bin/env julia

using DataFrames
using MyPkg

function dosomething()
   # do something
end
dosomething()

Currently I use Julia 0.6.3 and run the backtest with the command:
/home/jock/repos/private/MyPkg.jl/scripts/backtest

I am now trying to migrate MyPkg to Julia 0.7, so I’ve created a julia0p7 branch for MyPkg.
I have also installed Julia 0.7.0-alpha.0, symlinked it to /usr/local/bin/julia0p7 and changed the 1st line of the script to #! /usr/bin/env julia0p7. That is, the script will now try to run with Julia 0.7-0-alpha.

When I run the script as before I get a LoadError because DataFrames is not found in the current path.
I have read the latest documentation, which describes how to start a new project from scratch.
But I’m quite confused about how to migrate this existing package.
I tried various snippets from the docs but to no avail.
Can anyone point out some specific steps in this scenario?

Thanks in advance
Jock