WGLMakie slider issue

I have 2 scripts that can be reproduced here:

they are the same script, but one in GLMakie, one in WGLMakie

The GLMakie script works as intended, but the WGLMakie slider is not responsive. I don’t know why, because if I run the lines inside the on do, they work.

Thank you for your help!


I wrote 2 additional MWE scripts in the repo linked above, with sliders in GLMakie and WGLMakie, in 2D Axis.

They both work fine.

I cleaned the 3D LScene script, to make it clearly similar to the MWE. The issue seems to be due to 3D issues in WGLMakie / JSServe that seem to be currently being worked on. I get the following error message:

An exception was thrown in JS: RangeError: offset is out of bounds
Additional message: Error during running onjs callback
([name, array, length]) => {
// TODO, why are these called with the initial values!?
if (length > 0) {
const new_values = deserialize_three(JSServe.deserialize_js(array));
const buffer = mesh.geometry.attributes[name];
let buffers;
let first_buffer;
let real_length;
let is_instance = false;
// First, we need to figure out if this is an instance / geometry buffer
if (name in instance_buffers) {
buffers = instance_buffers;
first_buffer = first_instance_buffer;
real_length = real_instance_length;
is_instance = true;
} else {
buffers = geometry_buffers;
first_buffer = first_geometry_buffer;
real_length = real_geometry_length;
if (length <= real_length[0]) {
// this is simple - we can just update the values
buffer.needsUpdate = true;
if (is_instance) {
mesh.geometry.instanceCount = length;
} else {
// resizing is a bit more complex
// first we directly overwrite the array - this
// won’t have any effect, but like this we can collect the
// newly sized arrays untill all of them have the same length
buffer.to_update = new_values;
if (
(x) =>
x.to_update &&