Warning: Package cuDNN not found in current path

I get this warning while using Flux on a CUDA GPU:

┌ Warning: Package cuDNN not found in current path.
│ - Run `import Pkg; Pkg.add("cuDNN")` to install the cuDNN package, then restart julia.
│ - If cuDNN is not installed, some Flux functionalities will not be available when running on the GPU.
└ @ FluxCUDAExt ~/.julia/packages/Flux/u7QSl/ext/FluxCUDAExt/FluxCUDAExt.jl:56

I tried pkg> add cuDNN, but nothing happened. Plus, I thought cuDNN was included in CUDA. What should I do?

The script generates the above warning (and other errors) in the following environment:

julia> VERSION

(@v1.9) pkg> st CUDA
Status `~/.julia/environments/v1.9/Project.toml`
  [052768ef] CUDA v5.0.0

(@v1.9) pkg> st Flux
Status `~/.julia/environments/v1.9/Project.toml`
  [587475ba] Flux v0.14.6

The same script runs fine in an older environment:

julia> VERSION

(@v1.8) pkg> st CUDA
Status `~/.julia/environments/v1.8/Project.toml`
⌅ [052768ef] CUDA v4.0.1

(@v1.8) pkg> st Flux
Status `~/.julia/environments/v1.8/Project.toml`
⌅ [587475ba] Flux v0.13.14
1 Like

I found a relevant part in the Flux documentation:

NVIDIA GPU support requires the packages CUDA.jl and cuDNN.jl to be installed in the environment. In the julia REPL, type ] add CUDA, cuDNN to install them.

Not sure what was wrong, but for some reason nothing happened when I tried to install cuDNN only by pkg> add cuDNN at the time of the original posting. After finding out the above part in the documentation, I executed pkg> add CUDA, cuDNN as instructed, and it started installing cuDNN.

1 Like

I didn’t find any documentation for cuDNN.jl. Do you see that? I even check on JuliaGPU but no hope. Here is the best I can, but CUDNN seems different to cuDNN.

Then you must have cuDNN.jl installed already.

cuDNN.jl is part of the CUDA.jl repository, https://github.com/JuliaGPU/CUDA.jl/tree/master/lib/cudnn.