WARNING: HttpParser had build errors. Julia 0.6


#1

Keep getting this error after a complete reinstall on Ubuntu 18.4:
trying Pkg.build(“HttpParser”) results in:

INFO: Building HttpParser
Info: Attempting to create directory /home/adrian/.julia/v0.6/HttpParser/deps/downloads
Info: Directory /home/adrian/.julia/v0.6/HttpParser/deps/downloads already exists
Info: Attempting to create directory /home/adrian/.julia/v0.6/HttpParser/deps/downloads
Info: Directory /home/adrian/.julia/v0.6/HttpParser/deps/downloads already exists
Info: Downloading file https://github.com/nodejs/http-parser/archive/v2.7.1.zip
Info: Done downloading file https://github.com/nodejs/http-parser/archive/v2.7.1.zip
Info: Attempting to create directory /home/adrian/.julia/v0.6/HttpParser/deps
Info: Directory /home/adrian/.julia/v0.6/HttpParser/deps already exists
Info: Path /home/adrian/.julia/v0.6/HttpParser/deps/src/http-parser-2.7.1 already exists
Info: Attempting to create directory /home/adrian/.julia/v0.6/HttpParser/deps/usr/lib
Info: Directory /home/adrian/.julia/v0.6/HttpParser/deps/usr/lib already exists
Info: Changing directory to /home/adrian/.julia/v0.6/HttpParser/deps/src/http-parser-2.7.1
Info: Changing directory to /home/adrian/.julia/v0.6/HttpParser/deps/src/http-parser-2.7.1
Info: Changing directory to /home/adrian/.julia/v0.6/HttpParser/deps/src
Info: Attempting to create directory /home/adrian/.julia/v0.6/HttpParser/deps/usr/lib
Info: Directory /home/adrian/.julia/v0.6/HttpParser/deps/usr/lib already exists
Info: Changing directory to /home/adrian/.julia/v0.6/HttpParser/deps/src
=============================[ ERROR: HttpParser ]==============================

LoadError: could not spawn setenv(make -j8 -C http-parser-2.7.1 library,String[“PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/snap/bin”, “TEXTDOMAIN=im-config”, “DEFAULTS_PATH=/usr/share/gconf/ubuntu.default.path”, “QT_ACCESSIBILITY=1”, “DBUS_SESSION_BUS_ADDRESS=unix:path=/run/user/1000/bus”, “NODE_ENV=production”, “XDG_SESSION_DESKTOP=ubuntu”, “SSH_AGENT_PID=1800”, “XDG_SESSION_TYPE=x11”, “JULIA_EDITOR=atom -a”, “LC_TIME=nb_NO.UTF-8”, “USER=adrian”, “LESSCLOSE=/usr/bin/lesspipe %s %s”, “QT_IM_MODULE=xim”, “XDG_CONFIG_DIRS=/etc/xdg/xdg-ubuntu:/etc/xdg”, “LC_NUMERIC=nb_NO.UTF-8”, “LC_MEASUREMENT=nb_NO.UTF-8”, “GNOME_SHELL_SESSION_MODE=ubuntu”, “USERNAME=adrian”, “GDMSESSION=ubuntu”, “LC_TELEPHONE=nb_NO.UTF-8”, “LESSOPEN=| /usr/bin/lesspipe %s”, “CLUTTER_IM_MODULE=xim”, “XDG_DATA_DIRS=/usr/share/ubuntu:/usr/local/share:/usr/share:/var/lib/snapd/desktop”, “SHELL=/bin/bash”, “GJS_DEBUG_OUTPUT=stderr”, “XDG_SEAT=seat0”, “XAUTHORITY=/run/user/1000/gdm/Xauthority”, “XDG_MENU_PREFIX=gnome-”, “GOOGLE_API_KEY=AIzaSyAQfxPJiounkhOjODEO5ZieffeBv6yft2Q”, “GTK_MODULES=gail:atk-bridge”, “GTK_IM_MODULE=ibus”, “SESSION_MANAGER=local/Tardis:@/tmp/.ICE-unix/1706,unix/Tardis:/tmp/.ICE-unix/1706”, “XMODIFIERS=@im=ibus”, “HOME=/home/adrian”, “TERM=xterm-256color”, “COLORTERM=truecolor”, “VTE_VERSION=5201”, “NODE_PATH=/usr/share/atom/resources/app.asar/exports”, “IM_CONFIG_PHASE=2”, “XDG_CURRENT_DESKTOP=ubuntu:GNOME”, “LANG=en_US.UTF-8”, “SHLVL=1”, “LOGNAME=adrian”, “LC_MONETARY=nb_NO.UTF-8”, “GNOME_DESKTOP_SESSION_ID=this-is-deprecated”, “XDG_RUNTIME_DIR=/run/user/1000”, “DESKTOP_SESSION=ubuntu”, “SSH_AUTH_SOCK=/run/user/1000/keyring/ssh”, “LC_ADDRESS=nb_NO.UTF-8”, “LC_PAPER=nb_NO.UTF-8”, “_=/usr/bin/env”, “GPG_AGENT_INFO=/run/user/1000/gnupg/S.gpg-agent:0:1”, “GNOME_TERMINAL_SCREEN=/org/gnome/Terminal/screen/1f778899_d26e_46ad_a535_335abf8eebd1”, “JULIA_NUM_THREADS=2”, “GNOME_TERMINAL_SERVICE=:1.108”, “PWD=/home/adrian”, “DISPLAY=:0”, “GJS_DEBUG_TOPICS=JS ERROR;JS LOG”, “SONAME=libhttp_parser.so”, “XDG_VTNR=2”, “MANDATORY_PATH=/usr/share/gconf/ubuntu.mandatory.path”, “XDG_SESSION_ID=2”, “LC_NAME=nb_NO.UTF-8”, “TEXTDOMAINDIR=/usr/share/locale/”, “LC_IDENTIFICATION=nb_NO.UTF-8”, “ATOM_HOME=/home/adrian/.atom”, “QT4_IM_MODULE=xim”, “WINDOWPATH=2”, “LS_COLORS=”, “OPENBLAS_MAIN_FREE=1”]): no such file or directory (ENOENT)
while loading /home/adrian/.julia/v0.6/HttpParser/deps/build.jl, in expression starting on line 80

================================================================================

================================[ BUILD ERRORS ]================================

WARNING: HttpParser had build errors.

  • packages with build errors remain installed in /home/adrian/.julia/v0.6
  • build the package(s) and all dependencies with Pkg.build("HttpParser")
  • build a single package by running its deps/build.jl script

================================================================================


#2
sudo apt-get install make gcc

Fixed the problem