VSCode Debug DataFrames error

I have only recently tried to use VSCode Debug features following this debug guide. It stuck at first line of my code.

using DataFrames,

with error

> Connecting to debugger... Done!

ERROR: LoadError: ArgumentError: Package DataStructures does not have Compat in its dependencies:
- You may have a partially installed environment. Try `Pkg.instantiate()`
  to ensure all packages in the environment are installed.
- Or, if you have DataStructures checked out for development and have
  added Compat as a dependency but haven't updated your primary
  environment's manifest file, try `Pkg.resolve()`.
- Otherwise you may need to report an issue with DataStructures
 [1] macro expansion
   @ .\loading.jl:1167 [inlined]
 [2] macro expansion
   @ .\lock.jl:223 [inlined]
 [3] require(into::Module, mod::Symbol)
   @ Base .\loading.jl:1144
 [4] include
   @ .\Base.jl:419 [inlined]
 [5] include_package_for_output(pkg::Base.PkgId, input::String, depot_path::Vector{String}, dl_load_path::Vector{String}, load_path::Vector{String}, concrete_deps::Vector{Pair{Base.PkgId, UInt64}}, source::String)
   @ Base .\loading.jl:1554
 [6] top-level scope
   @ stdin:1

I am on all latest versions - Julia 1.8.0, DataFrames 1.3.4, Julialang Extension 1.7.6 and VSCode 1.70.2 (Windows 10 64bit). I have tried manual install of Compat, upgrade DataFrames to v1.4.0, Julia 1.6.7, Julia 1.9.0 - all no success. On Julia REPL, the packages are OK, and I am able to run the code without debug mode in VSCode.

I actually have more packages (Gadfly, CSV, Optim, Statistics, etc) in my code, not sure what else I might encounter.

Appreciate your help. Thanks

I don’t know what I did specifically, but after many attempts it is now proceeding to the debug mode.