VS Code extension v0.13.0 release candidate

We just finished a release candidate v0.13.0.rc.3 for the Julia extension for VS code here. We’d much appreciate it if we could get some testers to try it out and give feedback on bugs before we release it to the marketplace.

This new version doesn’t have many new user facing features:

  • We added support for Julia 1.3 (this is really the main feature).
  • We added configuration settings for the code formatting functionality (YES, you can format your Julia code with the extension).
  • We fixed your favorite bug so that the linter enable/disable setting should actually work in this version.
  • There is a fair bit of internal code reorganization and bug fixing in this release.

@ZacLN might know about more new things that I forgot :slight_smile:

If you can, please opt into the crash reporting of the extension! It makes finding and fixing bugs a lot easier for us.

To try the release candidate download the VSIX file from https://github.com/julia-vscode/julia-vscode/releases/download/v0.13.0-rc.3/language-julia-0.13.0-rc.3.vsix and install using the Extensions: Install from VSIX… command.

I’ll keep adding messages to this thread as we release more release candidates.

Thanks,
David and Zac

19 Likes

I have updated the extension and now I’m getting the error:

“execute code block only works once the julia language server is ready”

1 Like

Yes, you probably have to wait until all the packages are indexed again. Making the LS more responsive before that is finished is on our TODO list.

So, just be patient and wait :slight_smile:

1 Like

I have tried reinstalling v0.13.0 rc2 or v0.12.3 but now something doesn’t work.
When I start VSCode (with a .jl file opened) it doesn’t automatically start Julia, it only shows the powershell.
I can manually start Julia on that terminal but it doesn’t seem to be linked to my source code. Only commands run on the terminal work.
Do you know how can I solve this problem @davidanthoff ?

I keep getting the “Execute code block only works once Julia Language Server is Ready”.

UPDATE:
I’ve found I can execute line by line with Ctrl+Enter, but Alt+Enter doesn’t work. I think it was working before upgrading the extension.

Thank you for your great effort. I tried v0.13.0.rc. It works fine. I am very happy that the linter can be turned on and off. I am looking forward to hearing that the extension also supports debugging like the one in Juno.

Interesting. I had disabled the Julia extension because it seemed to consume a lot of processing power while seemingly idle. So perhaps it was due to this indexing? Is it possible to see that it is indexing? Will it restart indexing when new packages are added?

You can look at the output pane for the Julia Language Server, and it will have a log message when it is done. We clearly need to find a better solution for all of this. If you add a package, it will just index that one package, so once you are over the initial long indexing phase, it normally is quite ok.

We have a new release candidate, please download it from: https://github.com/julia-vscode/julia-vscode/releases/tag/v0.13.0-rc.4.

Only bug fixes in this new build.

Please download, install, test and keep sending crash reports and bug reports!

3 Likes

And we have release candidate 5:

We are pretty optimistic that this is the last one. If we could get a large number of folks testing this build, it would be awesome!

3 Likes

Thanks for this! Working great for me with julia 1.3 on Linux. I’m wondering what the main way you hope to receive feedback about the release candidate is? Is it mostly through the vscode telemetry or is it useful for folks to provide positive feedback here? I assume that if things are not working then creating an issue in the julia-vscode repo is the right thing to do?

Cheers and thanks again for all the work on this!

Positive feedback here is fantastic!!

If the language server crashes, the most helpful thing is to send the crash report, no need to open an extra issue in that case. Any other problem, opening an issue is probably best.

1 Like

We released 0.13.1 to the marketplace, so everyone should be getting it soon. Thanks for all the feedback, bug reports etc.!

4 Likes

I’m still gettint the
“Execute code block only works once the Julia Language Server is ready.” error when I use Alt+Enter.

What am I doing wrong?

Very likely, it is because the Julia Language Server have yet to finish loading.
It takes quite a bit of time on the first run, especially if you have a lot of packages.

In the Terminal Window, if you select “Options - Julia Language Server”, you can see its progress, it will say “store set” when its done.

If you have many packages like I do, this might end up taking a full day, so do keep that in mind (unfortunate, but hopefully will improve in future iterations)

Did you really mean a full day as in 24 hours?

Well, it took about 16 hours, so a full working day. I do have a lot of packages that I play around with though, so it might not be as long for others.

This is only done once, after it finish loading, it loads immediately.

Wow, that’s on the order of 100,000,000,000,000 instruction cycles. What is it doing that takes so long?

P.S. Some weeks back I tried VS Code but couldn’t get it to work properly with Julia. I didn’t spend any time debugging (Juno was/is working for me) but now I wonder if I just didn’t wait long enough.

It’s loading, precompiling, and inspecting all packages you have installed (or maybe only in the active environment?).

That is an excellent question :slight_smile: We are trying to figure out right now why it has slowed down that much. It was never fast, but this seems really excessively slow.

1 Like

Where is that option?