V0.7.0 or v1.0.0?

question
package
release

#1

I see both v0.7.0 and v1.0.0 tags are both available. I’m on v0.6.4. Should I just go straight to v1.0.0?

Are there some “migration” instructions? E.g., I see that v0.7.0 (and presumably v1.0.0) has different package management. I have a REQUIRE file for v0.6.4; how do I use it to “bootstrap” my v0.7.0/v1.0.0 system?

What else should I be aware of? Any Jupyter or JupyterLab issues?


#2

The advice from the core-devs provided earlier regarding this question is as follows: If you port 0.6->0.7.0->1.0, then the first port 0.6->0.7 will give you many deprecation warnings that you can fix all at once. When they are all fixed, the port 0.7->1.0 should work without a hitch. On the other hand, 0.6->1.0 will break your code (no deprecations, just errors), so it is more tedious to fix the errors. I’m not quite there yet, so I can’t give you advice based on my own experience.


#3

Thanks for your reply.

Is there an easy/fast method to determine package compatibility? For example, I have dozens of packages in my v0.6.4 REQUIRE and those packages require other packages. Out of all those packages, which have breaking issues for v0.7.0/v1.0.0?


#4

The juliacon2018 package management presentation was great. It answered a lot of questions and calmed my change-phobia.