Upgrading to v0.7 Type Error in version_data!


#1

I would like to update my Juniper package to v0.7 but get the following error atm on travis:

The command "if [[ -a .git/shallow ]]; then git fetch --unshallow; fi" exited with 0.
54.58s$ julia --check-bounds=yes -e 'Pkg.clone(pwd()); Pkg.build("Juniper"); Pkg.test("Juniper"; coverage=[secure])'
WARNING: Base.Pkg is deprecated, run `using Pkg` instead
 in module Main
┌ Warning: Pkg.clone is only kept for legacy CI script reasons, please use `add`
└ @ Pkg.API /buildworker/worker/package_linux64/build/usr/share/julia/stdlib/v0.7/Pkg/src/API.jl:424
  Updating registry at `~/.julia/registries/General`
  Updating git-repo `https://github.com/JuliaRegistries/General.git`
┌ Warning: package  at /home/travis/build/lanl-ansi/Juniper.jl will need to have a [Julia]Project.toml file in the future
└ @ Pkg.Types /buildworker/worker/package_linux64/build/usr/share/julia/stdlib/v0.7/Pkg/src/Types.jl:619
 Resolving package versions...
 Installed NaNMath ────────────── v0.3.1
 Installed URIParser ──────────── v0.4.0
 Installed DataStructures ─────── v0.10.0
 Installed DiffRules ──────────── v0.0.6
 Installed CommonSubexpressions ─ v0.2.0
 Installed ForwardDiff ────────── v0.7.5
 Installed StaticArrays ───────── v0.8.2
 Installed Calculus ───────────── v0.4.0
 Installed DiffResults ────────── v0.0.3
 Installed MathProgBase ───────── v0.6.4
 Installed SpecialFunctions ───── v0.6.0
 Installed BinDeps ────────────── v0.8.8
 Installed ReverseDiffSparse ──── v0.8.1
 Installed JuMP ───────────────── v0.18.2
  Updating `~/.julia/environments/v0.7/Project.toml`
  [2ddba703] + Juniper v0.2.0+ [`~/build/lanl-ansi/Juniper.jl`]
  Updating `~/.julia/environments/v0.7/Manifest.toml`
  [9e28174c] + BinDeps v0.8.8
  [49dc2e85] + Calculus v0.4.0
  [bbf7d656] + CommonSubexpressions v0.2.0
  [864edb3b] + DataStructures v0.10.0
  [163ba53b] + DiffResults v0.0.3
  [b552c78f] + DiffRules v0.0.6
  [f6369f11] + ForwardDiff v0.7.5
  [4076af6c] + JuMP v0.18.2
  [2ddba703] + Juniper v0.2.0+ [`~/build/lanl-ansi/Juniper.jl`]
  [fdba3010] + MathProgBase v0.6.4
  [77ba4419] + NaNMath v0.3.1
  [89212889] + ReverseDiffSparse v0.8.1
  [276daf66] + SpecialFunctions v0.6.0
  [90137ffa] + StaticArrays v0.8.2
  [30578b45] + URIParser v0.4.0
  Building SpecialFunctions → `~/.julia/packages/SpecialFunctions/kvjJ/deps/build.log`
WARNING: Base.Pkg is deprecated, run `using Pkg` instead
 in module Main
  Building SpecialFunctions → `~/.julia/packages/SpecialFunctions/kvjJ/deps/build.log`
WARNING: Base.Pkg is deprecated, run `using Pkg` instead
 in module Main
WARNING: Base.Pkg is deprecated, run `using Pkg` instead
 in module Main
   Testing Juniper
 Resolving package versions...
ERROR: TypeError: in version_data!, in typeassert, expected VersionNumber, got Pkg.Types.VersionSpec
Stacktrace:
 [1] version_data!(::Pkg.Types.Context, ::Array{Pkg.Types.PackageSpec,1}) at /buildworker/worker/package_linux64/build/usr/share/julia/stdlib/v0.7/Pkg/src/Operations.jl:345
 [2] apply_versions at /buildworker/worker/package_linux64/build/usr/share/julia/stdlib/v0.7/Pkg/src/Operations.jl:490 [inlined]
 [3] #add_or_develop#55(::Array{Base.UUID,1}, ::Function, ::Pkg.Types.Context, ::Array{Pkg.Types.PackageSpec,1}) at /buildworker/worker/package_linux64/build/usr/share/julia/stdlib/v0.7/Pkg/src/Operations.jl:1102
 [4] add_or_develop at /buildworker/worker/package_linux64/build/usr/share/julia/stdlib/v0.7/Pkg/src/Operations.jl:1084 [inlined]
 [5] (::getfield(Pkg.Operations, Symbol("##37#40")){Bool,getfield(Pkg.Operations, Symbol("##58#60")),Pkg.Types.Context,Pkg.Types.PackageSpec,Pkg.Types.Context})(::String) at /buildworker/worker/package_linux64/build/usr/share/julia/stdlib/v0.7/Pkg/src/Operations.jl:810
 [6] mktempdir(::getfield(Pkg.Operations, Symbol("##37#40")){Bool,getfield(Pkg.Operations, Symbol("##58#60")),Pkg.Types.Context,Pkg.Types.PackageSpec,Pkg.Types.Context}, ::String) at ./file.jl:595
 [7] mktempdir(::Function) at ./file.jl:593
 [8] #with_dependencies_loadable_at_toplevel#35(::Bool, ::Function, ::Function, ::Pkg.Types.Context, ::Pkg.Types.PackageSpec) at /buildworker/worker/package_linux64/build/usr/share/julia/stdlib/v0.7/Pkg/src/Operations.jl:795
 [9] #with_dependencies_loadable_at_toplevel at ./none:0 [inlined]
 [10] macro expansion at ./logging.jl:299 [inlined]
 [11] #test#56(::Bool, ::Function, ::Pkg.Types.Context, ::Array{Pkg.Types.PackageSpec,1}) at /buildworker/worker/package_linux64/build/usr/share/julia/stdlib/v0.7/Pkg/src/Operations.jl:1218
 [12] #test at ./none:0 [inlined]
 [13] #test#44(::Bool, ::Base.Iterators.Pairs{Union{},Union{},Tuple{},NamedTuple{(),Tuple{}}}, ::Function, ::Pkg.Types.Context, ::Array{Pkg.Types.PackageSpec,1}) at /buildworker/worker/package_linux64/build/usr/share/julia/stdlib/v0.7/Pkg/src/API.jl:234
 [14] #test at ./none:0 [inlined]
 [15] #test#43 at /buildworker/worker/package_linux64/build/usr/share/julia/stdlib/v0.7/Pkg/src/API.jl:217 [inlined]
 [16] #test at ./none:0 [inlined]
 [17] #test#42 at /buildworker/worker/package_linux64/build/usr/share/julia/stdlib/v0.7/Pkg/src/API.jl:216 [inlined]
 [18] #test at ./none:0 [inlined]
 [19] #test#41 at /buildworker/worker/package_linux64/build/usr/share/julia/stdlib/v0.7/Pkg/src/API.jl:215 [inlined]
 [20] (::getfield(Pkg.API, Symbol("#kw##test")))(::NamedTuple{(:coverage,),Tuple{Bool}}, ::typeof(Pkg.API.test), ::String) at ./none:0
 [21] top-level scope at none:0
The command "julia --check-bounds=yes -e 'Pkg.clone(pwd()); Pkg.build("Juniper"); Pkg.test("Juniper"; coverage=[secure])'" exited with 1.

So this is the error line:

ERROR: TypeError: in version_data!, in typeassert, expected VersionNumber, got Pkg.Types.VersionSpec

Not really sure where it comes from.
In general what are the best articles to read to update to v0.7 or what do I need to know?

Thanks in advance!


#2

Please open an issue on the Pkg.jl repo.