Trouble installing ZeroMQ when installing IJulia in ArchWSL

Hi. I am having problems installing ZMQ when I try to install IJulia.
I am using ArchLinux in WSL2 on Win10 version 19041, julia version 1.3.1.
Servel weeks ago I have successfully installed IJulia. For some reason I have to reinstall but get this error:

(v1.3) pkg> add IJulia
Updating registry at ~/.julia/registries/General
Updating git-repo
┌ Warning: Some registries failed to update:
│ — /home/wuli/.julia/registries/General — failed to fetch from repo
└ @ Pkg.Types /build/julia/src/julia-1.3.1/usr/share/julia/stdlib/v1.3/Pkg/src/Types.jl:1199
Resolving package versions…
ERROR: Unable to automatically install ‘ZeroMQ’ from /home/wuli/.julia/packages/ZeroMQ_jll/SbMEz/Artifacts.toml’
[1] (::Pkg.Artifacts.var"#kw##ensure_artifact_installed")(::NamedTuple{(:platform, :verbose),Tuple{Pkg.BinaryPlatforms.Linux,Bool}}, ::typeof(Pkg.Artifacts.ensure_artifact_installed), ::String, ::Dict{String,Any}, ::String) at ./none:0
[2] do_add!(::Dict{Symbol,Any}, ::Array{Pkg.Types.PackageSpec,1}, ::Dict{Symbol,Any}) at /build/julia/src/julia-1.3.1/usr/share/julia/stdlib/v1.3/Pkg/src/REPLMode.jl:505

I deleted ~/.julia and retry but get the same error.

Thank you for your help!

1 Like

I have solved it myself, it’s a proxy problem

1 Like

How did you solve it? I have the same problem on Windows 7

1 Like

Just use a proxy, caution that socks5 is not supported by libgit2

1 Like

Could you please detail it? I didn’t get how to solve the problem.

Because I live in China, a proxy is needed to get full speed access to github and, I set up a shadowsocksR in windows host and access the network behind it in wsl. I just set $http_proxy and $https_proxy to http://$win_host:8128/ and the problem solved, where 8128 is the port my ssr listening to, the default may be 1080.
If you are using wsl2 too, you may get the windows host by running
cat /etc/resolv.conf | grep nameserver | awk '{print $2}'
If you are using wsl1, simply use

Could you tell me the detail of your environment, may be you have a different problem form me.

1 Like

I solved it in the only way I’m capable of, I copied “.julia” from a computer that was working and pasted in the one that wasn’t.

Thanks for your help anyway.

sorry to disturb. I’m new for julia. How to change the proxy?(because i live in China too…