Travis CI fails for Julia v0.7 since Test package missing


#1

Changed the ModiaMath travis.yml file to use Julia 0.7. Now, travis cl fails with the message:

$ julia --check-bounds=yes --color=yes -e "if VERSION < v\"0.7.0-DEV.5183\"; Pkg.test(\"${JL_PKG}\", coverage=true); else using Pkg; Pkg.test(coverage=true); end"
   Testing ModiaMath
 Resolving package versions...
ERROR: LoadError: ArgumentError: Package Test not found in current path:
- Run `Pkg.add("Test")` to install the Test package.

What needs to be fixed?


#2

Maybe this will help
https://docs.julialang.org/en/latest/stdlib/Pkg/#Test-specific-dependencies-1


#3

I have a similar question.

I tried the following

[targets]
test = ["Test"]
build = ["Libdl"]

but, although I added the “Libdl” in the targets part. I still get error when build. Does this mean that currently only test target is supported?


#4

Thanks, this fixed the issue.


#5

Correct, unfortunately the build target is not yet hooked up the way the test target is so for now your package will have to have build dependencies among the main dependencies just as they were in the old system. In the future, however, we will hook this up so that you can avoid having the main package depend on things you only need for building the package.