Although it’s probably too late, a name like uniquerows
would be more self-explanatory than allunique
.
Thanks for your excellent work!
Although it’s probably too late, a name like uniquerows
would be more self-explanatory than allunique
.
Thanks for your excellent work!
allunique
is the function name in Base Julia that does the job. Therefore we reuse it so that users do not need to learn a new name. If the user knows unique
then allunique
is natural.
This is a general rule we follow. Functions from Base Julia that operate on collections are used in DataFrames.jl to operate on rows (examples: push!
, unique
, deleteat!
, …). In other words: although DataFrame
is not iterable it is considered by these functions as a collection of rows.
I was confused about the function’s purpose, as I didn’t know uniqueall
in Base. Now I just tried it and got it. Thank you!
Naming things is always one of the hardest parts of the design (and that is why such feedback and discussion is valuable to make sure we made right choices).