Suddenly REPL in vscode becomes weird

Usually i use shift + enter to excute my julia code line by line, but suddenly it dosen’t work. For example, if i excute e = 1+1 then i had got following:

julia> e = 1+1

Now, i get following:


I don’t know why, and it’s very uncomfortable(Plots is the worst). How can i fix it?

ps. I guess ‘Shell integration’ is not relevent to this issue. I tried change configuration(changing unable that).

1 Like

I can’t repro that. What OS are you on? What does “I tried change configuration(changing unable that).” mean? Did you restart the REPL after changing the setting?

This slightly reminds me if this

But it is hard to say from your post if this may be related.

Sorry for my english and enviroment check!

  1. I repro on my two computers, windows 10 and 11 with same env: julia 1.7.3, vscode 1.70.0, julia extension v1.6.29.
  2. The dots next to julia> are about ‘Shell integration’ feature and suddenly appeared(today), same time with issue, so i had guess that’s the problem. “I tried change configuration(changing unable that).” means that i turn off the ‘Shell integration’ option in vscode but doesn’t work.
  3. Yes. To be clear, REPL itself has no trouble. When i type on REPL directly, the code are excuted well. If i excute with ctrl+enter or shift+enter in text editor, that occurs.

Ah, turns out this only happens when the julia.execution.resultType setting is set to both or REPL. Change that to inline for now; we should have a fix released in a few hours.


In case it is useful to anyone: I also had to deactivate the Code in REPL option

1 Like

v1.6.30 fixes this issue and should be out now.


I’m on v1.6.30 and have julia.execution.resultType set to both and I am seeing incredible lags on printing to the REPL.

should help with that.

1 Like

Hi @pfitzseb, now that there is a new version of the julia extension, I wanted to try to get the shell integration back. I renabled the terminal shell integration, but the cicles next to the julia prompt in the REPL no longer appear. Any thoughts on how I can get this back? I see the space where the circles should be, but there are no circles. If I disable the shell integration, the space (indentation) where the circles should be disappear…

Here are my terminal settings in vscode:

Windows 10 OS
julia-vscode extension v1.7.4
Julia v1.8.0

I’ve disabled shell integration on Windows until we can figure out how to get performance up to snuff.


Oh ok. sounds good. Thanks!