Strange Error at Installing Packages `git` failed to clone


Well, most of them (if not all) are Base. You can for instance run using Iterators without adding it.

In a command line, run git --version. What’s the output?

I don’t know if that has anything to do with that, but a weird package problem I had once was solved with this:

Those packages are so called stdlibs, packages which are included with Julia and don’t require a download.

I agree that there’s little obvious system to that. Are you behind a firewall that can interfere with your network traffic? Do you have antivirus software that may overreact to certain files? Does git cloning of the difficult packages work outside of Julia? E.g.

git clone

This looks unrelated since it’s git cloning that fails. Here I would rather suggest trying with the package servers, but since that’s the default and has apparently been disabled I assume that has already been tried.

1 Like

Thanks so much @GunnarFarneback . Yes, I think that this might be related to the firewall or some proxy settings. What is weird is that I can enter to or to through the browser, however, it does not work to download the packages through Julia.

I will try to clone things through the shell to see what I get. However, can you think of any other diagnostic or fix?

1 Like
C:\Users\XXX>git --version
"git" no se reconoce como un comando interno o externo,
programa o archivo por lotes ejecutable.

I get this output. It basically says in Spanisg something like git is not recognized as an internal or external command, program or file

Git cloning packages does not work in the cmd for example. Weird

$ git clone
Cloning into 'Preferences.jl'...
fatal: unable to access '': SSL certificate problem: self signed certificate in certificate chain

I’m not sure how Julia works with this, I never used Julia on a computer where I hadn’t already installed git, but it might be a good idea to google how to install git on Windows and do so. Can’t swear it will help though.

In Git I get the following

$ git --version
git version

$ git clone
Cloning into 'Preferences.jl'...
fatal: unable to access '': SSL certificate problem: self signed certificate in certificate chain

Might be an antivirus problem, apparently


I have no experience of SSL failures so can’t really help more than point to GitHub - JuliaLang/NetworkOptions.jl, which mentions a bit of SSL.

I solved the Git issue with the SSL certificates, for example now this works,

$ git clone
Cloning into 'Preferences.jl'...
remote: Enumerating objects: 91, done.
remote: Counting objects: 100% (91/91), done.
remote: Compressing objects: 100% (62/62), done.
remote: Total 91 (delta 27), reused 72 (delta 21), pack-reused 0
Receiving objects: 100% (91/91), 29.99 KiB | 438.00 KiB/s, done.
Resolving deltas: 100% (27/27), done

I can clone Distributions using the bash as well. However, I still get errors when adding packages to Julia, for example with Distributions:

(@v1.6) pkg> add ""
     Cloning git-repo ``
    Updating git-repo ``
    Updating registry at `C:\Users\alfaroua\.julia\registries\General`
    Updating git-repo ``
   Resolving package versions...
     Cloning [1a297f60-69ca-5386-bcde-b61e274b549b] FillArrays from
   Installed FillArrays ───── v0.11.7
     Cloning [692b3bcd-3c85-4b1f-b108-f13ce0eb3210] JLLWrappers from
ERROR: failed to clone from, error: GitError(Code:ERROR, Class:OS, failed to read data: El servidor devolvió una respuesta no válida o no reconocida

try using the bundled SSL?

1 Like

Thanks so much for the suggestion.

I tried to do this by following the steps on @StefanKarpinski post and got the following error


(@v1.6) pkg>  add ""
     Cloning git-repo ``
ERROR: failed to clone from, error: GitError(Code:ERROR, Class:SSL, Your Julia is built with a SSL/TLS engine that libgit2 doesn't know how to configure to use a file or directory of certificate authority roots, but your environment specifies one via the JULIA_SSL_CA_ROOTS_PATH variable. If you believe your system's root certificates are safe to use, you can `export JULIA_SSL_CA_ROOTS_PATH=""` in your environment to use those instead.)

(@v1.6) pkg>

You have two options:

  1. Add your firewall’s certificate to the Windows system root cert store (and don’t try to use a PEM file, since libgit2 can’t do that)

  2. Tell Julia not to verify by setting the appropriate options via environment variable documented in NetworkOptions.jl

1 Like

Hi thanks so much!

Can you please elaborate on the second option? What is the exact command I should write?

I am sorry, but I am having such a hard time understanding this error.

Is the second option, writing the following in my startup file

@eval Module() begin

    import NetworkOptions



Try ENV["JULIA_SSL_NO_VERIFY_HOSTS"] = "**" (see examples in the README). Also, it should be enough to set it, you don’t need to import NetworkOptions.

3 posts were split to a new topic: Failed to add package by https URL