Segfault when using PackageCompiler on aarch64 on Julia 1.6.0 and up

It worked just fine before upgrading to Julia 1.6.0. Now when I try to use compile_app it gives a segfault part way through. It doesn’t crash, but I haven’t tried waiting long after the segfault.

[westly08:06~]$ julia -q --project
julia> using PackageCompiler

julia> create_app("EPUBCreate", "EPUBCreate-linux-aarch64-bin")
  0 dependencies successfully precompiled in 6 seconds (20 already precompiled)
  1 dependency errored. To see a full report either run `import Pkg; Pkg.precompile()` or load the package
[ Info: PackageCompiler: creating base system image (incremental=false)...

signal (11): Segmentation fault
in expression starting at /home/westly/julia-1.6.1/share/julia/stdlib/v1.6/LinearAlgebra/src/matmul.jl:808
__aarch64_sync_cache_range at /workspace/srcdir/gcc-7.1.0/libgcc/config/aarch64/sync-cache.c:54
_ZN4llvm3sys6Memory26InvalidateInstructionCacheEPKvm at /home/westly/julia-1.6.1/bin/../lib/julia/libLLVM-11jl.so (unknown line)
Allocations: 87104104 (Pool: 87081079; Big: 23025); GC: 111

It’s always had that dependency error and worked fine before.

1 Like

I’m seeing the same with Julia 1.7.x as well as nightly releases. Did you manage to work around this?

Late reply, but on what specific AArch64 CPUs is this? I’ve noticed this only on NVIDIA ARM CPUs, and filed Segfault during JIT memory invalidation · Issue #41852 · JuliaLang/julia · GitHub.

1 Like

Yup. I’m seeing this on nVidia TX2 ARM CPU.